Bug 993528 - Issues with KPI panels configuration of JBPM Dashboard
Issues with KPI panels configuration of JBPM Dashboard
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 02:37 EDT by Jan Hrcek
Modified: 2014-08-06 16:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-08-06 02:37:22 EDT
There are some issues with the configuration of KPI panels of JBPM Dashboard.

1) Panels that use date based values for Domain (X Axis) use Interval's size "-Predefined-" which results in seconds being used on X axis. It would make better sense to use "Days" as interval size. The issue is present for following KPIs:
-Tasks started by date
-Tasks completed by date
-Process initiated by date



2) Some panels don't have "Show title" option enabled. Please enable that option for the following panels to make the configuration consistent (not to mention, that our selenium tests rely on panel title to be displayed in order to find the chart in the DOM ;):
-Process initiated by date
-Tasks by status


3) The KPIs that display "count of something" use decimal values for Range (Y Axis). This is not really a bug, but doesn't make much sense and introduces unecessary visual clutter (for example 2.5 process instances started or 0.995 tasks completed by given date). The issue is there for the following charts:
-Instances started by user
-Number of task instances
-Number of tasks per user
-Tasks completed by date
-Process completed by date
-Process initiated by date
Comment 1 David Gutierrez 2013-09-06 11:48:13 EDT
Issues #1 & #2 have been fixed as indicated. Issue #3 has been fixed by adding support to integer values in NVD3 charts and enabling such setting on the specified charts.

 
Github commits (master):

- https://github.com/droolsjbpm/jbpm-dashboard/commit/33c683ca5f56de6dcb9df3c002a353acc11bbe08

- https://github.com/droolsjbpm/dashboard-builder/commit/9b1af0960aedd5226269b953cd32b7339656f3f8

Github commits (6.0.x):

- https://github.com/droolsjbpm/dashboard-builder/commit/3f26d3f40104e87e4d821912ebbfa550b3fcc65e

- https://github.com/droolsjbpm/jbpm-dashboard/commit/1afb03a58525e226b1f58d9330100fac7541e1db
Comment 5 Jan Hrcek 2013-10-18 02:22:35 EDT
Ok, verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.