Bug 993540 - jBPM Designer does not show reasonable message when importing/opening incorrect bpmn2 definition
jBPM Designer does not show reasonable message when importing/opening incorre...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity high
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 03:03 EDT by Radovan Synek
Modified: 2014-08-06 16:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrect process definition (9.88 KB, application/xml)
2013-08-06 03:03 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-06 03:03:24 EDT
Created attachment 783212 [details]
incorrect process definition

The process definition (attached) contains incorrect reference in attribute bpmnElement of bpmndi:BPMNPlane element. When I try to import this definition into Designer (after opening new BPMN2 process, using "Import from BPMN2") error message appears telling me "Failed to import BPMN2. Check server logs for more details." 

There is no information about what is wrong with the process definition. User (business analytic could be a typical user of jBPM Designer) should not be forced to check server logs. This user very probably doesn't know where is some server log and he should not have access to it.

I also tried to get this incorrect definition into the Designer by pushing to the corresponding repository inside .niogit. I haven't managed to open this definition - this time jBPM Designer did not load at all, so I was not even informed that I should look at a server log.
Comment 1 Radovan Synek 2013-08-06 03:23:54 EDT
Tested with community 6.0.0.CR1
Comment 2 Prakash Aradhya 2013-09-16 17:21:31 EDT
Its a must fix for GA

Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 3 Tihomir Surdilovic 2013-11-04 12:20:18 EST
Designer shows a message where users can see details of the error during load (log messages). Empty process is presented to user after.
Comment 4 Prakash Aradhya 2013-11-04 13:24:20 EST
Tiho,
Have you made any update in the code compared to what it used to be before ?

At the minimum there should be a pop up dialog saying the process could not be opened due to errors and the log should have soem comprehensive details on what those errors are.
Comment 5 Marek Baluch 2013-11-05 10:03:04 EST
Prakash, 

what do you mean when you say log?

If you mean the server log then I don't think it is a good solution to dump the details to the server log only. An analyst should not be required to contact the administrator to get the error message why the process import did not succeed.
Comment 6 Radovan Synek 2013-12-03 09:50:28 EST
Verified on BPMS-6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.