Bug 99356 - Raid kernel modules missing in NFS install
Raid kernel modules missing in NFS install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-17 19:30 EDT by Phil Anderson
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-22 11:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Anderson 2003-07-17 19:30:13 EDT
Description of problem:
The raid1 module is not loaded when doing a NFS (and possibly other type)
install with RAID-1 partitions.  This causes the installer to exit with a fatal
error, due to mke2fs failing, which in turn is due to mkraid failing.  mkraid
puts the message "Personality 3 not loaded" in the syslog, which indicates that
the raid1 module isn't loaded.  I belive this is also a problem with raid0, raid5.

This problem doesn't occur when doing a CD install.

mkraid also doesn't work when doing a NFS rescue either.

How reproducible:
Always

Steps to Reproduce:
1. Perform a Redhat 9 NFS installation createing a RAID-1 partition

Actual Results:  Installer fails with fatal error ("Personality 3 not loaded" in
syslog)

Expected Results:  Everything should work :)
Comment 1 Jeremy Katz 2003-07-17 20:15:40 EDT
We always attempt to load all of the RAID modules.  Does your boot disk use a
different kernel version than the modules on the second stage?

Could you attach both /tmp/anaconda.log and /tmp/syslog?
Comment 2 Phil Anderson 2003-07-17 20:28:42 EDT
One blaring omission I forgot to mention, was that I was using the Dell RH9
Install CD, which I think uses an updated kernel to fix some USB bug.  I'll have
another go tomorrow with the normal redhat boot disks and see how I go.  I'll
keep you posted.

I do remember I encountered same problem when sitting my RHCE exam, which caused
me great greif, but that was with Redhat 8.
Comment 3 Phil Anderson 2003-07-20 20:16:15 EDT
I don't have any machines that I'm able to nuke anymore, so I'm unable to verify
that the dell cd's updated kernel was the problem, but I'm guessing it probably
was, otherwise I'm sure someone else would have reported the bug by now.
Comment 4 Jeremy Katz 2003-07-22 11:29:07 EDT
If there's an updated kernel, there must be a complete updated installer tree to
go with it, otherwise, you will not have matching modules in stage2.  If Dell is
providing things where this isn't the case, you will have to go to them for
support of it -- we can only support what we've shipped.

Note You need to log in before you can comment on or make changes to this bug.