Bug 993561 - "WARNING: Failed to broadcast over UDP" appears in jenkins.log when git push change to a jenkins app
"WARNING: Failed to broadcast over UDP" appears in jenkins.log when git push ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ben Parees
libra bugs
:
Depends On:
Blocks: 1116823
  Show dependency treegraph
 
Reported: 2013-08-06 03:48 EDT by Meng Bo
Modified: 2015-05-14 20:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1116823 (view as bug list)
Environment:
Last Closed: 2014-07-15 06:27:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-08-06 03:48:17 EDT
Description of problem:
Create jenkins server, and touch any blank file under the repo. Git push the change. And check the jenkins.log via rhc tail.

We can found in the jenkins.log:
WARNING: Failed to broadcast over UDP
java.net.BindException: Permission denied
	at java.net.PlainDatagramSocketImpl.bind0(Native Method)
	at java.net.AbstractPlainDatagramSocketImpl.bind(AbstractPlainDatagramSocketImpl.java:95)
	at java.net.DatagramSocket.bind(DatagramSocket.java:376)
	at java.net.MulticastSocket.<init>(MulticastSocket.java:172)
	at java.net.MulticastSocket.<init>(MulticastSocket.java:137)
	at hudson.UDPBroadcastThread.<init>(UDPBroadcastThread.java:69)
	at jenkins.model.Jenkins.<init>(Jenkins.java:822)
	at hudson.model.Hudson.<init>(Hudson.java:81)
	at hudson.model.Hudson.<init>(Hudson.java:77)
	at hudson.WebAppMain$2.run(WebAppMain.java:214)


Version-Release number of selected component (if applicable):
devenv_3616

How reproducible:
always

Steps to Reproduce:
1.Create jenkins server
2.Do some changes in the git repo and push them
3.Check the jenkins.log

Actual results:
Some warning message appears in the jenkins.log

Expected results:
No such warning meesages.

Additional info:
Since AWS is not allowed broadcast/multicast over UDP, we should disable such modules to avoid the warning/error messages.
Comment 1 Andy Goldstein 2013-08-07 16:50:26 EDT
It looks like this commit adds support to disable it by setting a Java system property: https://github.com/jenkinsci/jenkins/commit/19f34b54d6cd69f837552a21d8adb41f3b5fba91

I think this was first introduced in Jenkins 1.514
Comment 2 Ben Parees 2013-12-16 11:03:06 EST
Waiting on testing of update to latest jenkins.
Comment 3 openshift-github-bot 2014-01-03 13:06:50 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/48f66cdf01510560bbf4bfda1313813da405987a
bug 993561: WARNING: Failed to broadcast over UDP appears in jenkins.log when git push change to a jenkins app
Comment 4 Ben Parees 2014-01-10 11:26:46 EST
The fix for this is prepared but until we move up to jenkins 1.540+ we don't have all the pieces aligned to deliver it.

The version of jenkins that supports disabling UDP also requires that the openshift-jenkins-plugin needs to pass "-jar-cache $OPENSHIFT_DATA_DIR/.jenkins/cache/jars" on the slave launch to avoid putting the jar-cache in a non-writeable directory.
Comment 6 Meng Bo 2014-07-02 02:17:46 EDT
Checked on devenv_4932, with disable_jenkins_udp_broadcast present, the UDP broadcast error will not show anymore.

Jul 02, 2014 6:11:53 AM jenkins.InitReactorRunner$1 onAttained
INFO: Completed initialization
Jul 02, 2014 6:11:54 AM org.springframework.web.context.support.StaticWebApplicationContext prepareRefresh
INFO: Refreshing org.springframework.web.context.support.StaticWebApplicationContext@1a3dda2: display name [Root WebApplicationContext]; startup date [Wed Jul 02 06:11:54 EDT 2014]; root of context hierarchy
Jul 02, 2014 6:11:54 AM org.springframework.web.context.support.StaticWebApplicationContext obtainFreshBeanFactory
INFO: Bean factory for application context [org.springframework.web.context.support.StaticWebApplicationContext@1a3dda2]: org.springframework.beans.factory.support.DefaultListableBeanFactory@1b1786
Jul 02, 2014 6:11:54 AM org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@1b1786: defining beans [authenticationManager]; root of factory hierarchy
Jul 02, 2014 6:11:54 AM org.springframework.web.context.support.StaticWebApplicationContext prepareRefresh
INFO: Refreshing org.springframework.web.context.support.StaticWebApplicationContext@f4821d: display name [Root WebApplicationContext]; startup date [Wed Jul 02 06:11:54 EDT 2014]; root of context hierarchy
Jul 02, 2014 6:11:54 AM org.springframework.web.context.support.StaticWebApplicationContext obtainFreshBeanFactory
INFO: Bean factory for application context [org.springframework.web.context.support.StaticWebApplicationContext@f4821d]: org.springframework.beans.factory.support.DefaultListableBeanFactory@a02f4f
Jul 02, 2014 6:11:54 AM org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@a02f4f: defining beans [filter,legacy]; root of factory hierarchy
Jul 02, 2014 6:11:55 AM hudson.WebAppMain$3 run
INFO: Jenkins is fully up and running

Note You need to log in before you can comment on or make changes to this bug.