Bug 993562 - sysrq configuration not honoured
sysrq configuration not honoured
Status: CLOSED DUPLICATE of bug 1007150
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 03:50 EDT by Karel Volný
Modified: 2013-09-12 15:39 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 15:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-08-06 03:50:17 EDT
Description of problem:
My machine just hanged on poweroff. As I had enabled sysrq before, I've tried to halt it via the magic key combos. Bad luck, the only thing I could do was sync.

Version-Release number of selected component (if applicable):
systemd-204-9.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. # echo "kernel.sysrq = 1" > /etc/sysctl.d/sysrq.conf
2. reboot
3. $ cat /proc/sys/kernel/sysrq

Actual results:
16

Expected results:
1

Additional info:
https://fedoraproject.org/wiki/QA/Sysrq#How_do_I_enable_the_magic_SysRq_key.3F
Comment 1 Kamil Dudka 2013-08-14 10:04:40 EDT
You can use the following to work around the bug:

# cp /usr/lib/sysctl.d/50-default.conf /etc/sysctl.d/
# sed -i 's/kernel.sysrq = 16/kernel.sysrq = 1/' /etc/sysctl.d/50-default.conf
Comment 2 Karel Volný 2013-08-29 10:25:26 EDT
but there are multiple settings in that file, what if something changes in the future and the change will go unnoticed due to the local copy?
Comment 3 Lennart Poettering 2013-09-12 15:39:30 EDT

*** This bug has been marked as a duplicate of bug 1007150 ***

Note You need to log in before you can comment on or make changes to this bug.