Bug 993610 - Exception is thrown when inserting fact via REST API
Exception is thrown when inserting fact via REST API
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER3
: 6.0.0
Assigned To: Marco Rietveld
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 05:38 EDT by Radovan Synek
Modified: 2016-09-20 01:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full stacktrace (7.41 KB, text/x-log)
2013-08-06 05:38 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-06 05:38:35 EDT
Created attachment 783252 [details]
full stacktrace

Inserting a simple fact (just String instance) via REST /runtime/{id}/execute ended with an exception:
Unable to add result from InsertObjectCommand because of UnsupportedOperationException: java.lang.UnsupportedOperationException: Result type DefaultFactHandle from command InsertObjectCommand is an unsupported response type. 

It seems that the command itself can be processed, but the result - DefaultFactHandle cannot be serialized in JaxbCommandsResponse class.

Attaching full stacktrace.

version: community 6.0.0.CR1
Comment 3 Marco Rietveld 2013-08-29 03:09:26 EDT
Fixed, with these commits: 

https://github.com/droolsjbpm/droolsjbpm-integration/commit/3b417388eba873649ee10df28a3df961ebafa6b4
https://github.com/droolsjbpm/droolsjbpm-integration/commit/5ac8be32fd07aaf54389cbedaac25c7d9b2ee82c

Not sure which milestone this is, please set this bug to modified (and set the milestone).
Comment 4 Radovan Synek 2013-09-18 09:21:02 EDT
Verified on BPMS-6.0.0.ER3

Note You need to log in before you can comment on or make changes to this bug.