Bug 993632 - functional keys not working via vnc or vnc-module
functional keys not working via vnc or vnc-module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
19
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 06:24 EDT by vde
Modified: 2014-01-20 12:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-20 12:33:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vde 2013-08-06 06:24:07 EDT
Description of problem:

when connected to Fedora 19 via Xrdp-VNC not works special control keyboard combinations such as language selection, Xwindows restart and so on, so computer seems to be completly unusable.

Version-Release number of selected component (if applicable):

tigerVNC 1.3 that comes as update to fc19
downgrade to tigerVNC 1.2 solves this problem

How reproducible:

1 install tigerVNC and xrdp
2 add national keyboard layout such as Russian
3 connect via Remmina to VNC or RDP port
3 try to switch language or restart x-windows


Actual results:
system completely ignores such combinations and language remains english

Expected results:
русские буквы


Additional info:
as I saw in tigerVNC source they near completely rewrote xserver/hw/vnc/Input.cc so error is somewhere there
Comment 1 Tim Waugh 2014-01-20 11:45:49 EST
I'm trying to reproduce this but I'm not seeing the problem.

On Fedora 20 I've installed remmina and remmina-plugins-vnc.

On a Fedora 19 VM I've installed tigervnc-server-module and configured /etc/X11/xorg.conf.d/10-libvnc.conf to enable the "vnc" plugin with no password. The VM was installed with British keyboard layout but I have added Russian keyboard layout as an input source using the Settings application.

On the Fedora 20 system I configured remmina to connect via VNC to the Fedora 19 VM, and set the input source for the VNC viewer window to Russian.

As well as the regular "typing" keys seeming to be fine, special keys such as Calculator, Volume Up/Down, Web/Home all worked fine. I was also able to switch input source in the VNC session using Super+Space (after grabbing all keyboard input with Control_R).

Could you please give more details on what you are seeing?
Comment 2 vde 2014-01-20 11:55:17 EST
Yes now is all OK for me too, thanks
Comment 3 Tim Waugh 2014-01-20 12:33:05 EST
OK, great.

Note You need to log in before you can comment on or make changes to this bug.