Bug 993633 - NPE in org.jboss.ejb.client.remoting.ChannelAssociation.releaseChannelMessageOutputStream
NPE in org.jboss.ejb.client.remoting.ChannelAssociation.releaseChannelMessage...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: GA
: EAP 6.2.0
Assigned To: David M. Lloyd
Ladislav Thon
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 06:35 EDT by Ladislav Thon
Modified: 2015-10-19 00:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-07 08:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Thon 2013-08-06 06:35:03 EDT
During EAP 6.1.1.ER4 testing, we've seen this exception:

11:40:46,086 ERROR [org.jboss.as.ejb3.invocation] (EJB default - 3) JBAS014134: EJB Invocation failed on component ForwardingStatefulSBImpl for method public abstract int org.jboss.test.clusterbench.common.ejb.CommonStatefulSB.getSerialAndIncrement(): javax.ejb.EJBException: java.lang.NullPointerException
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.handleExceptionInOurTx(CMTTxInterceptor.java:165) [jboss-as-ejb3-7.2.1.Final-redhat-5.jar:7.2.1.Final-redhat-5]
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInOurTx(CMTTxInterceptor.java:250) [jboss-as-ejb3-7.2.1.Final-redhat-5.jar:7.2.1.Final-redhat-5]
	at org.jboss.as.ejb3.tx.CMTTxInterceptor.required(CMTTxInterceptor.java:315) [jboss-as-ejb3-7.2.1.Final-redhat-5.jar:7.2.1.Final-redhat-5]
	...
Caused by: java.lang.NullPointerException
	at org.jboss.ejb.client.remoting.ChannelAssociation.releaseChannelMessageOutputStream(ChannelAssociation.java:280) [jboss-ejb-client-1.0.23.Final-redhat-1.jar:1.0.23.Final-redhat-1]
	at org.jboss.ejb.client.remoting.RemotingConnectionEJBReceiver.processInvocation(RemotingConnectionEJBReceiver.java:240) [jboss-ejb-client-1.0.23.Final-redhat-1.jar:1.0.23.Final-redhat-1]
	at org.jboss.ejb.client.EJBClientInvocationContext.sendRequest(EJBClientInvocationContext.java:181) [jboss-ejb-client-1.0.23.Final-redhat-1.jar:1.0.23.Final-redhat-1]
	...

This is a scenario with a standalone client and 2 clusters (client -> forwarding cluster -> target cluster and back) and the exception happens in the forwarding cluster when the node is being shut down.

Log is at https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-2clusters-ejbremote-shutdown-repl-async/14/console-perf21/
Comment 1 Jaikiran Pai 2013-08-06 06:36:55 EDT
This is fixed in 1.0.24 version of EJB client library (which isn't released yet). If this is critical, let me know, I'll release it tonight.
Comment 2 Ladislav Thon 2013-08-06 06:46:38 EDT
I believe that this isn't critical, as we only hit it in a single test and it happens after the server (which is also the client) has been shut down.
Comment 3 Jitka Kozana 2013-10-01 02:52:39 EDT
Update from 6.2.0.ER3 testing: this error was seen again (as expected, ER3 contains ejb client library v. 1.0.23), but the frequency of this got up: around 30 NPEs in one test running 20 mins.

Link to client log:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-ejbremote-jvmkill-dist-async/30/console-perf17/consoleText
Comment 7 Aristides Neto 2013-10-10 13:53:24 EDT
Hi I'm having this NPE very frequently, I'm currently using the EAP6.1.0 (tried with EAP 6.1.1 also). Where I can find this 1.0.24 version of the client libray? Thank you
Comment 9 Dimitris Andreadis 2013-10-24 14:28:35 EDT
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.
Comment 10 Jan Martiska 2014-07-08 10:23:53 EDT
6.3.0.ER9 contains EJB client 1.0.25.Final, 6.2.0.GA contains 1.0.24.Final.. So I suppose this should be fixed already. Ladislav, could you have a look?
Comment 11 Ladislav Thon 2014-07-09 02:30:52 EDT
Right, this was last seen in 6.2.0.ER3, which had 1.0.23. EJB client was upgraded to 1.0.24 in 6.2.0.CR1 (fix for this issue is in https://github.com/jbossas/jboss-ejb-client/commit/0a4a558), so this is indeed fixed in 6.2.0 already.

Note You need to log in before you can comment on or make changes to this bug.