Bug 993637 - mount should load loop driver when needed
mount should load loop driver when needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 06:44 EDT by Bruno Wolff III
Modified: 2013-08-09 21:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 21:15:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2013-08-06 06:44:35 EDT
Description of problem:
Loop devices are no longer precreated. So that mounting using loop devices will fail unless you run modprobe loop first.


Version-Release number of selected component (if applicable):
util-linux-2.23.2-1.fc20.i686

Steps to Reproduce:

[root@bruno bruno]# mount -o loop Fedora-Live-XFCE-i686-19-1.iso /mnt
mount: /home/bruno/Fedora-Live-XFCE-i686-19-1.iso: failed to setup loop device: No such file or directory
[root@bruno bruno]# modprobe loop
[root@bruno bruno]# mount -o loop Fedora-Live-XFCE-i686-19-1.iso /mnt
[root@bruno bruno]#
Comment 1 Bruno Wolff III 2013-08-09 21:15:25 EDT
This is working again in rawhide. My guess is that there was a kernel issue as there had been a change affecting this that was made recently. I ay have seen it later than some people because there is a dracut issue affecting booting and I needed to revert dracut to boot with recent kernels.

Note You need to log in before you can comment on or make changes to this bug.