This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 993640 - rfe: cli: get-zones should print vertical table, not a horizontal line
rfe: cli: get-zones should print vertical table, not a horizontal line
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 06:45 EDT by Petr Sklenar
Modified: 2013-11-12 07:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 07:23:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-08-06 06:45:57 EDT
Description of problem:
get-zones should print vertical table, not a horizontal line

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1, sudo firewall-cmd --get-zones
work drop internal external trusted home dmz public block

2, sudo firewall-cmd --get-services
cluster-suite kpasswd bacula-client smtp ipp radius mysql ms-wbt bacula transmission-client ftp mdns samba pmproxy dhcpv6-client rpc-bind ldaps https ldap dhcp imaps samba-client vnc-server http dns pmwebapi ntp kerberos telnet libvirt openvpn ssh pmwebapis pmcd ipsec postgresql ipp-client proxy-dhcp amanda-client mountd tftp-client dhcpv6 nfs tftp pop3s libvirt-tls


Actual results:
output in the line

Expected results:
output in the table
or at least table when used with '|'
sudo firewall-cmd --get-services | grep mountd 

Additional info:
Comment 3 Jiri Popelka 2013-08-16 09:22:14 EDT
(In reply to Petr Sklenar from comment #0)
> Actual results:
> output in the line

Yes, it's not been the prettiest output, I agree.
 
> Expected results:
> output in the table
> or at least table when used with '|'

The first think we need to do is sort them. After this commit:
https://git.fedorahosted.org/cgit/firewalld.git/commit/?id=ab88d1acf18257d78c4eb118565e25b3b0be333e

# sudo firewall-cmd --get-services
amanda-client bacula bacula-client cluster-suite dhcp dhcpv6 dhcpv6-client dns ftp http https imaps ipp ipp-client ipsec kerberos kpasswd ldap ldaps libvirt libvirt-tls mdns mountd ms-wbt mysql nfs ntp openvpn pmcd pmproxy pmwebapi pmwebapis pop3s postgresql proxy-dhcp radius rpc-bind samba samba-client smtp ssh telnet tftp tftp-client transmission-client vnc-server wbem-https

which is a little better.

But I don't think for example the following table makes it more arranged.

cluster-suite    dhcp         dhcpv6
dhcpv6-client    dns          ftp
http             https        imaps
ipp              ipp-client   ipsec
kerberos         kpasswd      ldap
ldaps            libvirt      libvirt-tls
mdns             mountd       ms-wbt
mysql            nfs          ntp
...              ...          ...

For checking "by eye" the 'one line' output seems to be quicker for me.
Anybody any ideas ?

> sudo firewall-cmd --get-services | grep mountd 

this has been possible even now and I don't think changing the output to table would improve it:

# sudo firewall-cmd --get-services | grep ssh; echo $?
... ssh ...
0
# sudo firewall-cmd --get-services | grep sshd; echo $?
1
Comment 4 Thomas Woerner 2013-11-12 07:23:33 EST
We can not change this. There is already documentation and also a book, which would need changes because of this.

But this might be possible in a major release later on.

Closing as WONTFIX for now.

Note You need to log in before you can comment on or make changes to this bug.