Bug 993680 - bacula possibly affected by F-20 unversioned docdir change
bacula possibly affected by F-20 unversioned docdir change
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
: Reopened
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 07:38 EDT by Ville Skyttä
Modified: 2013-08-06 10:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 10:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 07:38:19 EDT
bacula was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Simone Caronni 2013-08-06 08:31:56 EDT
Just did a couple of rebuilds this morning and I can confirm bacula it is not affected.

Sample f20 build, unversioned docdir:

http://koji.fedoraproject.org/koji/buildinfo?buildID=454434

Same build for f19, versioned docdir:

http://koji.fedoraproject.org/koji/buildinfo?buildID=454436

All documents in Bacula are simply added with %doc in the files section.

Regards,
--Simone
Comment 2 Ville Skyttä 2013-08-06 08:36:13 EDT
The -console-bat subpackage still uses versioned doc dir. Looking at the grep lines as suggested would have revealed this pretty easily...

http://koji.fedoraproject.org/koji/rpminfo?rpmID=4304337
Comment 3 Simone Caronni 2013-08-06 08:55:21 EDT
Oops, sorry, I missed that.
Looking at it I also noticed that the license file is not always present on the hard drive with a subselection of packages installed.
Comment 4 Simone Caronni 2013-08-06 10:03:57 EDT
OK fixed it, rebuilding it now. This also exposed the fact that bat was using files in %_docdir for runtime; so I will push an update also for f18/f19.

http://pkgs.fedoraproject.org/cgit/bacula.git/commit/?id=65662da44842095629b8bc1d7015ee0f718abf5a

Regards,
--Simone

Note You need to log in before you can comment on or make changes to this bug.