Bug 993686 - bochs possibly affected by F-20 unversioned docdir change
bochs possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bochs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lalancette
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
: Reopened
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 07:39 EDT by Ville Skyttä
Modified: 2013-08-14 09:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 16:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 07:39:55 EDT
bochs was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Gwyn Ciesla 2013-08-08 09:38:54 EDT
Looks like a false positive.
Comment 2 Ville Skyttä 2013-08-08 16:08:22 EDT
(In reply to Jon Ciesla from comment #1)
> Looks like a false positive.

But isn't, which would have been easy to catch by looking at the grep output as suggested:

$ grep -A 2 -B 2 -E "(/doc|_docdir|_defaultdocdir).+version" bochs.spec 
# Fix up some man page paths.
sed -i \
  -e 's|/usr/local/share/doc/bochs/|%{_docdir}/%{name}-%{version}/|' \
  -e 's|/usr/local/share/|%{_datadir}/|' \
  doc/man/*.*
Comment 3 Gwyn Ciesla 2013-08-09 10:34:17 EDT
I saw the grep output, but I'm not sure what needs to be fixed here.  I built this in mock for rawhide, and I get an unversioned docdir, and the paths referenced in the man pages match that.  What's the problem.
Comment 4 Ville Skyttä 2013-08-10 03:54:05 EDT
Indeed, the man pages have /usr/share/doc/bochs/ hardcoded. That means that the mentioned sed does nothing to them (it looks for /usr/local/...) and that at the moment the path is correct for Rawhide and incorrect in earlier distros.

I suggest dropping this line from the sed altogether:

  -e 's|/usr/local/share/doc/bochs/|%{_docdir}/%{name}-%{version}/|' \

...or adjusting it to match /usr/share/doc/bochs/ and to modify to %{_pkgdocdir} (+ adding its conditional definition) if you want to fix this for earlier distros.
Comment 5 Gwyn Ciesla 2013-08-13 16:07:29 EDT
Dropped.  Thanks!
Comment 6 Ville Skyttä 2013-08-14 03:46:05 EDT
BTW the other sed line that was removed in 2.6.2-4 in addition to the one I suggested was not a noop:

$ grep -r usr/local/share doc/man/*
doc/man/bochs-dlx.1:/usr/local/share/bochs/dlxlinux/bochsrc.txt or run bochs(1)
doc/man/bochsrc.5:"share" directory which is typically /usr/local/share/bochs on UNIX
Comment 7 Gwyn Ciesla 2013-08-14 09:42:38 EDT
Right you are, fixed.

Note You need to log in before you can comment on or make changes to this bug.