Bug 993687 - boost possibly affected by F-20 unversioned docdir change
boost possibly affected by F-20 unversioned docdir change
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 07:40 EDT by Ville Skyttä
Modified: 2013-08-12 05:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-11 17:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 07:40:08 EDT
boost was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Petr Machata 2013-08-11 17:29:23 EDT
The only matching line is a comment.  I updated the comment to be in sync with unversioned docdir change.
Comment 2 Ville Skyttä 2013-08-12 04:23:15 EDT
Ok. But by the way, regarding the comment's content:

# As the %doc macro erases the target directory

This is no longer true as of rpm >= 4.9.1, http://rpm.org/ticket/836
Comment 3 Petr Machata 2013-08-12 05:32:21 EDT
Great, so we shouldn't need to go through the temporary directory.  I'll update the boost spec.

Note You need to log in before you can comment on or make changes to this bug.