Bug 9937 - Window operations slow down over time in Gnome
Window operations slow down over time in Gnome
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: David Mason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-03 14:29 EST by Ted Giering
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-11 12:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Giering 2000-03-03 14:29:24 EST
After Gnome has been running for about a week, I notice that certain
window operations, in particular changing window focus and closing windows,
slow down.  This seems to be particularly pronounced when closing windows.
The contents of the window is blacked out and remains that way for up to a
couple of seconds before it disappears.  While it is in this state, the
mouse is frozen.  This makes it inconvenient to close many windows in
succession.  The slowdown is cumulative over time, or possibly with use;
the longer the session is up, the slower it gets.
	I have not noticed this with KDE.  I always run Gnome with Enlightenment
and KDE with the KDE window manager, so I don't know if the problem is in
Gnome, Enlightenment, or a combination of the two.
Comment 1 Ted Giering 2000-05-10 19:06:59 EDT
I have found that when window operations slow down, restarting the Gnome panel
(that is, killing it from the shell and allowing it to restart itself) restores
the performance I see just after starting the session.  I have upgraded to
Enlightenment 0.16.4 and am using its pager and iconbox features to replace the
Gnome pager and window list.  I have turned off these features in the panel, and
have not seen a problem with window slowdown since.
Comment 2 David Mason 2000-05-11 12:34:59 EDT
A new GNOME release is coming out soon which includes many fixes and updates to
the Panel... including the GNOME Pager which has been replaced with the Desk
Guide... this applet has been a source of many issues of this nature. We will
see if the new release fixes these issues - which in the initial review seems
likely.

Note You need to log in before you can comment on or make changes to this bug.