Bug 993708 - ConsoleKit possibly affected by F-20 unversioned docdir change
ConsoleKit possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 07:44 EDT by Ville Skyttä
Modified: 2013-08-12 05:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: ConsoleKit-0.4.5-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 04:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 07:44:28 EDT
ConsoleKit was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Dan Mashal 2013-08-12 04:58:46 EDT
ConsoleKit is deprecated. I'll worry about it if it starts failing to build.
Comment 2 Ville Skyttä 2013-08-12 05:16:47 EDT
That's not proper package maintenance, please orphan it and let someone else take over if you're not interested. I took care of this issue in Rawhide.
Comment 3 Dan Mashal 2013-08-12 05:20:44 EDT
Again, the package is dead and slated for retirement.
Comment 4 Ville Skyttä 2013-08-12 05:56:39 EDT
Until it actually is retired, it should be maintained just like everything else, so again, comment 2 still applies.
Comment 5 Dan Mashal 2013-08-12 05:58:01 EDT
OK, thanks for fixing it.

Note You need to log in before you can comment on or make changes to this bug.