This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 993710 - cpptasks possibly affected by F-20 unversioned docdir change
cpptasks possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpptasks (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs 992092
  Show dependency treegraph
 
Reported: 2013-08-06 07:44 EDT by Ville Skyttä
Modified: 2013-08-11 07:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: cpptasks-1.0b5-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-11 07:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix rhbz#992092, rhbz#993710 (11.04 KB, patch)
2013-08-10 07:00 EDT, gil cattaneo
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2013-08-06 07:44:55 EDT
cpptasks was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 gil cattaneo 2013-08-10 07:00:56 EDT
Created attachment 785163 [details]
fix rhbz#992092, rhbz#993710

- fix rhbz#992092, rhbz#993710
- switch to XMvn
- resolve some rpmlint problems
- install LICENSE NOTICE files in javadoc sub package
- use pom macros
- minor changes to adapt to current guideline
- add %%pre javadoc script

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=5801446
Comment 2 Fedora Admin XMLRPC Client 2013-08-11 05:47:56 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Mat Booth 2013-08-11 07:51:11 EDT
cpptasks-1.0b5-11 has been built for rawhide:

https://koji.fedoraproject.org/koji/buildinfo?buildID=456006

Note You need to log in before you can comment on or make changes to this bug.