Bug 993725 - dmlite possibly affected by F-20 unversioned docdir change
dmlite possibly affected by F-20 unversioned docdir change
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dmlite (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alejandro Alvarez
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 07:51 EDT by Ville Skyttä
Modified: 2013-08-30 08:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 08:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 07:51:20 EDT
dmlite was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Alejandro Alvarez 2013-08-30 08:26:14 EDT
Build for F20:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5873008

Build for F21:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5873403


In the resulting -doc package the directory is now /usr/share/doc/dmlite instead of /usr/share/doc/dmlite-0.6.1

Note You need to log in before you can comment on or make changes to this bug.