Bug 993737 - gui: zones should be more visibly described
gui: zones should be more visibly described
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 07:57 EDT by Tomas Dolezal
Modified: 2013-10-23 10:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 10:33:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-08-06 07:57:18 EDT
Description of problem:
Zones  should be more precisely described in firewall-config:
* what is their purpose (somewhere on the right, not in a tooltip)
* make visual difference between immutable and mutable zones
* immtuable zones should not be editable (firewalld-0.3.4-1.fc19.noarch bug!) and not even have options visible (because user won't see any difference between trusted/blocked/drop)

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1

How reproducible:
always

Steps to Reproduce:
1. use firewall-config GUI

Expected results:
please fix or provide information why do you think it shouldn't be fixed this way
thanks

Additional info:
CCed affiliated users
Comment 3 Tomas Dolezal 2013-08-06 08:45:02 EDT
please note that it also requires zone description, not only things connected with immutable zones
Comment 4 Jiri Popelka 2013-08-16 10:11:50 EDT
(In reply to Tomáš Doležal from comment #0)
> Zones  should be more precisely described in firewall-config:
> * what is their purpose (somewhere on the right, not in a tooltip)

Do you mean individual zones or generally ?

> * make visual difference between immutable and mutable zones
> * immtuable zones should not be editable (firewalld-0.3.4-1.fc19.noarch
> bug!) and not even have options visible (because user won't see any
> difference between trusted/blocked/drop)

Well, this has been an intended change in 0.3.4.
We decided that the concept of 'immutable' uselessly complicates things, for example the biggest problem was that if you want to permanently add an interface to a zone you need to modify that zone and that was impossible with immutable zones. I don't think there's any use in restricting users what zones they can or can't modify. Initially we wanted to restrict the immutableness only on some entries like services/ports/etc. (which does not make a sense to add to a trusted/block/drop) but not on interfaces (which we need to be able to add to a trusted/block/drop). But because we had not seen a way how to do that (allow to modify/add only some entries) in GUI we decided to drop it completely.
Comment 5 Tomas Dolezal 2013-08-16 10:32:00 EDT
(In reply to Jiri Popelka from comment #4)
> > Zones  should be more precisely described in firewall-config:
> > * what is their purpose (somewhere on the right, not in a tooltip)
> Do you mean individual zones or generally ?

for individual zones, to highlight their differences. important for formerly immutable zones.
I see major difference between block/drop in the default policy (reject or drop). In the mentioned release I did not find anything about it, only at wiki (and maybe manpage, which is for cli)

Is it possible to show/allow change the default policy?
Comment 6 Thomas Woerner 2013-10-23 10:33:17 EDT
We do not have immutable zones anymore, all zones are mutable.

All zones are customizable, therefore there is no easy way to have descriptions for the zones that match the zone even after the user modified the zone.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.