Bug 993740 - rich language> log level
rich language> log level
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Thomas Woerner
Tomas Dolezal
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 08:02 EDT by Petr Sklenar
Modified: 2015-03-05 08:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 08:22:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-08-06 08:02:22 EDT
Description of problem:
manpage: log level is not much described and it seems to be optional.
But log level is mandatory in the cmd tool.

Version-Release number of selected component (if applicable):
That's rfe.

How reproducible:
always

Steps to Reproduce:
1.log level is mandatory
but man page says: [level="log level"] ~ optional

2. Whats the log level?, is it for firewalld or rsyslog?

Actual results:
Its mandatory.
Description of these levels.

Expected results:
1,
edit man that's mandatory
or
make some log level default

2, please add into man page tiny description about each log level values. Or where to find (like see man syslog ... )

Additional info:
Comment 3 Jiri Popelka 2013-10-02 09:37:21 EDT
(In reply to Petr Sklenar from comment #0)
> But log level is mandatory in the cmd tool.

Should be optional. Fixed upstream with
https://git.fedorahosted.org/cgit/firewalld.git/commit/?id=ffe3dc00e103ebe6a0ac83c880456ab31f0d09fb
 
> 2, please add into man page tiny description about each log level values. Or
> where to find (like see man syslog ... )

Added with
https://git.fedorahosted.org/cgit/firewalld.git/commit/?id=323db01cb507d0040da9585deb61b712d1b3901c
Comment 6 Tomas Dolezal 2014-01-28 11:40:14 EST
firewalld-0.3.9-3.el7.noarch partly verified

Jirko, would it be possible to amend the manpage firewalld.richlanguage(5) with the default loglevel? I've found it to be 4:warning.
Comment 7 Jiri Popelka 2014-01-28 12:36:01 EST
What about ?

Log level can be one of "emerg", "alert", "crit", "error", "warning", "notice", "info" or "debug", where default (i.e. if there's no one specified) is "warning".

https://git.fedorahosted.org/cgit/firewalld.git/commit/?id=3f1b42f3b87e64f384aa9fc508d8ef9dfd59b56c
Comment 8 Tomas Dolezal 2014-01-29 08:30:14 EST
Ok, this seems reasonable for me :)

please update bug status accordingly to make sure that ON_QA is not set until the package is rebuilt sometime, thanks.
Comment 18 errata-xmlrpc 2015-03-05 08:22:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0520.html

Note You need to log in before you can comment on or make changes to this bug.