Bug 993789 - Executing xrandr reverts previous resolution change
Executing xrandr reverts previous resolution change
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
7.0
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Regression
Depends On:
Blocks: 1026182
  Show dependency treegraph
 
Reported: 2013-08-06 08:15 EDT by Milan Barta
Modified: 2015-10-27 20:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1026182 1061942 (view as bug list)
Environment:
Last Closed: 2014-02-05 17:35:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remote-viewer --spice-debug log (232.08 KB, text/plain)
2013-08-06 08:16 EDT, Milan Barta
no flags Details
spice-vdagent log (888 bytes, text/plain)
2013-08-06 08:17 EDT, Milan Barta
no flags Details

  None (edit)
Description Milan Barta 2013-08-06 08:15:16 EDT
Description of problem:
After changing resolution of guest system in remote-viewer using xrandr and running xrandr command again afterwards, the resolution is reverted back to the previous one. According to xrandr output, the resolution is still the same as set previously.

Version-Release number of selected component (if applicable):
Host & client: RHEL 7 
    qemu-kvm-1.5.2-2.el7.x86_64
    spice-server-0.12.4-1.el7.x86_64
    virt-viewer-0.5.7-1.el7.x86_64)

Guest: 
Fedora 19: spice-vdagent-0.14.0-2.fc19.x86_64
RHEL 7: spice-vdagent-0.14.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. make sure spice-vdagent service is running in guest (resolution is 1024x768)
2. execute 'xrandr -s 640x480'
3. execute 'xrandr' to trigger the resolution reversion (with RHEL7 guest this step is not needed) 

Actual results:
Guest screen resolution changes back from 640x480 to 1024x768, even though xrandr output states the actual resolution is still 640x480.

Expected results:
Guest screen resolution stays the same as set.

Additional info:
Comment 1 Milan Barta 2013-08-06 08:16:25 EDT
Created attachment 783302 [details]
remote-viewer --spice-debug log
Comment 2 Milan Barta 2013-08-06 08:17:02 EDT
Created attachment 783303 [details]
spice-vdagent log
Comment 3 Hans de Goede 2013-08-06 10:07:18 EDT
This is a problem with the new kms driver, where the agent is no longer involved in the display resizing path. I've done some testing and it seems that monitor changes don't get seen by the guest (by gnome-settings-daemon?) until xrandr is run.

IE if you fullscreen the client window then running xrandr from a terminal will actually resize the guest to the fullscreen resolution, where one would expect the resize to happen immediately upon going fullscreen (tested with a fully up2date F-19).
Comment 4 Hans de Goede 2013-08-06 10:17:21 EDT
It seems that using kms also sometimes causes empty monitor config info to the client, ie during my F-19 tests I get various messages like these:

(remote-viewer:14603): GSpice-CRITICAL **: display_handle_monitors_config: assertion 'config->count > 0' failed
Comment 6 Søren Sandmann Pedersen 2014-01-10 15:03:30 EST
This doesn't reproduce for me with a RHEL 7 Beta 1 guest and host.

Is this still reproducible?
Comment 7 Milan Barta 2014-01-21 05:59:25 EST
In RHEL7 Beta1, I couldn't reproduce. However, the warning message as reported by Hans is still being printed.
Comment 8 Søren Sandmann Pedersen 2014-02-05 17:35:49 EST
I have filed 

    https://bugzilla.redhat.com/show_bug.cgi?id=1061942

to track the warning message.

Closing this bug since it isn't reproducible any more.

Note You need to log in before you can comment on or make changes to this bug.