Bug 993898 - QXL driver causes VM hang on shutdown
QXL driver causes VM hang on shutdown
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
7.0
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 08:58 EDT by Milan Barta
Modified: 2015-10-27 20:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 21:30:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spice debug with QXL driver (51.19 KB, text/plain)
2013-08-06 08:59 EDT, Milan Barta
no flags Details
Spice debug with CIRRUS driver (3.10 KB, text/plain)
2013-08-06 09:00 EDT, Milan Barta
no flags Details

  None (edit)
Description Milan Barta 2013-08-06 08:58:35 EDT
Description of problem:
VM fails to shutdown correctly when running it with Spice QXL driver. The VM freezes and never shuts down completely. This is reproducible 75 % of the time.

When qemu-kvm is executed with different -vga parameter (tested with 'cirrus'), the VM shuts down 100 % of the time correctly.

Version-Release number of selected component (if applicable):
Host & client: RHEL 7
Guest: RHEL7, (Fedora 19)

qemu-kvm-1.5.2-2.el7.x86_64
spice-server-0.12.4-1.el7.x86_64

xorg-x11-drv-qxl-0.1.1-0.13.20130703git8b03ec16.el7.x86_64
virt-viewer-0.5.7-1.el7.x86_64
spice-gtk-0.20-2.el7.x86_64
spice-vdagent-0.14.0-3.el7.x86_64

How reproducible:
75 %

Steps to Reproduce:
1. run a VM with qxl graphics driver (e.g. see qemu-kvm command below)
2. initiate shutdown from within the guest system

Actual results:
Guest hangs on shutdown.

Expected results:
Guest system shuts down completely and correctly.

Additional info:

qemu-kvm command:
/usr/libexec/qemu-kvm -m 768 -name r7 -drive file=/home/mbarta/rhel7.img,if=virtio -vga qxl -spice port=5901,addr=127.0.0.1,disable-ticketing,image-compression=off,streaming-video=off,playback-compression=off -device virtio-serial-pci -device virtserialport,chardev=spicechannel0,name=com.redhat.spice.0 -chardev spicevmc,id=spicechannel0,name=vdagent -device intel-hda -device hda-duplex
Comment 1 Milan Barta 2013-08-06 08:59:37 EDT
Created attachment 783316 [details]
Spice debug with QXL driver
Comment 2 Milan Barta 2013-08-06 09:00:12 EDT
Created attachment 783317 [details]
Spice debug with CIRRUS driver
Comment 4 Søren Sandmann Pedersen 2014-01-10 14:31:10 EST
Doesn't reproduce for me with RHEL 7 guest on RHEL 7 host, both as of approximately Beta1.

Does this still reproduce with a more recent RHEL 7?
Comment 5 Milan Barta 2014-01-21 06:02:50 EST
With RHEL7 Beta 1, I couldn't reproduce either. Looks like it's been fixed.

Note You need to log in before you can comment on or make changes to this bug.