Bug 993936 - Cannot cycle through 3 keyboard layouts using ALT+SHIFT
Cannot cycle through 3 keyboard layouts using ALT+SHIFT
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 09:17 EDT by Michal Domonkos
Modified: 2014-06-16 06:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 06:43:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Domonkos 2013-08-06 09:17:15 EDT
Description of problem:
Cannot cycle through selected keyboard layouts with ALT+SHIFT toggle if (and only if) having 3 layouts selected, either with "setxkblayout" or via the Gnome Keyboard dialog.

However, I'm able to switch between the first two layouts using either the left ALT+SHIFT combo (to switch to the first layout) or the right ALT+SHIFT combo (to switch to the second layout).

Switching works fine when having 2 or 4 layouts selected as well as when having a different toggle configured.

Not sure if it's related or not but some of the other toggles are misbehaving too, for example the CTRL+SHIFT toggle only works for the right CTRL and SHIFT keys, not the left ones.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-48.100.el5

How reproducible:
always

Steps to Reproduce:
1. In a terminal run: setxkbmap -layout "us,cz,ru" -option "grp:alt_shift_toggle"
2. In the same terminal type some text to test out the current layout (should be US)
3. Press ALT+SHIFT to switch to the CZ layout

Actual results: 
Nothing happens.

Expected results:
You should be able to cycle the layouts.
Comment 1 Michal Domonkos 2013-08-12 10:32:59 EDT
Just to update the reproducer from Comment 0:

3. Press _left_ ALT+SHIFT and verify the layout has been switched to CZ
4. Press _left_ ALT+SHIFT and verify the layout has been switched to RU
5. Press _left_ ALT+SHIFT and verify the layout has been switched to US
Comment 2 RHEL Product and Program Management 2014-02-24 19:13:44 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2014-03-07 07:15:14 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 4 Ondrej Vasik 2014-06-16 06:43:03 EDT
Closing WONTFIX, as this doesn't sound as a blocker in production phase 3 and was not escalated.

Note You need to log in before you can comment on or make changes to this bug.