Bug 993950 - tuxguitar possibly affected by F-20 unversioned docdir change
tuxguitar possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tuxguitar (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 09:25 EDT by Ville Skyttä
Modified: 2013-08-07 08:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 20:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 09:25:03 EDT
tuxguitar was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Orcan Ogetbil 2013-08-06 20:01:42 EDT
This was already fixed:
   http://koji.fedoraproject.org/koji/buildinfo?buildID=453927

I guess your script ran over an older version of the SPEC file.
Comment 2 Orcan Ogetbil 2013-08-06 20:04:50 EDT
Sorry the correct koji link is
   http://koji.fedoraproject.org/koji/buildinfo?buildID=453928
Comment 3 Ville Skyttä 2013-08-07 03:16:09 EDT
(In reply to Orcan Ogetbil from comment #1)
> I guess your script ran over an older version of the SPEC file.

I didn't, the grep still outputs those rows, but of course it doesn't know of the conditionals around it. BTW the first linked doc in the initial comment contains an alternative way of doing it which is better in the sense that it is somewhat cleaner to use overall, and doesn't require embedding distro version info in conditionals in the specfile.
Comment 4 Orcan Ogetbil 2013-08-07 08:48:44 EDT
Thanks Ville. I agree that the page shows a cleaner solution. But I guess I didn't see it (or it wasn't there) when I fixed the package. I'll change it when I need to work on the package next time. Best.

Note You need to log in before you can comment on or make changes to this bug.