Bug 993960 - RFE: Provide easy to use cheatsheet for main RHEV aspects
RFE: Provide easy to use cheatsheet for main RHEV aspects
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Cheryn Tan
ecs-bugs
:
Depends On:
Blocks: 902971
  Show dependency treegraph
 
Reported: 2013-08-06 09:28 EDT by Tomas Dosek
Modified: 2014-06-18 03:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 03:04:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dosek 2013-08-06 09:28:31 EDT
Description of problem:

Most of sysadmins consider RHEV documentation pretty "heavy"
to use. This results in very simple cases being opened with GSS.

Most of these cases would get easily solved by a sort of cheat sheet 
that would include some major aspects of RHEV installation/maintenance.

For instance:
RHEV-M installation:
Be sure these HW requirments are met:
Register to these channels:
Run this command:
Comment 2 Tomas Dosek 2013-08-06 10:00:26 EDT
What I mean is to have a one-sheet leaflet that would have sections:
Installation
-procedure
-rhn channels
Upgrade
-procedure
-rhn channels
Backup
-commands
-what to backup
Restore
-commands
Logcollector
-full
-incl. specific RHEV-H only
-DB only
Etc.
Comment 3 Cheryn Tan 2013-08-07 00:49:28 EDT
Hi Tomas, 

There are already resources which address your request, in particular the Quick Start Guide, which covers a checklist of hardware/ software requirements, manager and host installation, RHN channels, setting up resources in preparation for creating your first VM. 

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Quick_Start_Guide/index.html

As the Quick Start Guide is targeted for basic installation, it doesn't cover upgrade procedures, which are in the Install Guide instead: 

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Installation_Guide/index.html#chap-Upgrading_to_Red_Hat_Enterprise_Virtualization_3.2

The backup procedures are here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Administration_Guide/index.html#chap-Backups

And log collector:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Administration_Guide/index.html#sect-Collecting_Logs_with_the_Log_Collector_Tool

Troubleshooting tips:
https://access.redhat.com/site/articles/208933

Basically, I think what's really required here is educating users where to look in the documentation, because really, it's all available. The Quick Start Guide in particular is supposed to be this cheatsheet that you requested, except that we've defined the scope differently (ie, it doesn't cover backup/ log collector etc).

I know "read the guides" isn't high on most people's priority, and it's difficult to educate customers to do so. The only way I can really suggest is to point them to the docs when you resolve their cases, because really, creating another "cheatsheet" does not guarantee that customers would read that either. We've run tech talks for GSS-APAC and LATAM recently regarding the RHEV docs workflow and how to find information, and we're still looking for ways on how to encourage users to read the docs :)

If you have any questions about docs and where to look for information, feel free to jump on #rhev-docs or email rhev-docs@redhat.com. The writers are also on #sbr-virt, unfortunately we're mostly based in the Australian timezone. But we're happy to help out whenever we can, just reach out to us.

Thanks,
Cheryn

Note You need to log in before you can comment on or make changes to this bug.