Bug 993974 - mlpack possibly affected by F-20 unversioned docdir change
mlpack possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mlpack (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ryan Curtin
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 09:32 EDT by Ville Skyttä
Modified: 2013-08-06 14:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: mlpack-1.0.6-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 14:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 09:32:16 EDT
mlpack was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Ryan Curtin 2013-08-06 14:29:55 EDT
Changes made, link to successful Koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5786100
All documentation now is installed to /usr/share/doc/mlpack/ on F20 and /usr/share/doc/mlpack-1.0.6/ (or whatever the right version number is) on older than F20, which to my understanding is the desired behavior.

This also exposed a bug in the Doxygen build scripts, which is now fixed.

Note You need to log in before you can comment on or make changes to this bug.