Bug 9940 - php2 should have a .php2 extension and php3 should be .phtml
php2 should have a .php2 extension and php3 should be .phtml
Status: CLOSED WONTFIX
Product: Red Hat Secure Web Server
Classification: Retired
Component: mod_php3 (Show other bugs)
3.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-03 15:01 EST by Suso Banderas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-07 09:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suso Banderas 2000-03-03 15:01:25 EST
I've been bothered over the last year that the default httpd.conf file in
the apache rpms from Redhat use .php3 as the default extention for php3
files and .phtml as the extention for php2.  I've always thought that
.phtml(or maybe just .php) was the more logical choice for what represents
"current" version php files.
  Since php3 and php4 are syntatically compatible as far as I can tell it
would make migrating pages to php4 much easier.   If we keep on using
.php<version-number> as the default extension name, it will be more
difficult to make upgrades.

  So I think that instead the following directives should be used:

# For PHP3 and up.
<IfModule mod_php3.c>
  AddType application/x-httpd-php3 .phtml
  AddType application/x-httpd-php3-source .phps
</IfModule>
# The following is for PHP/FI (PHP2):
<IfModule mod_php.c>
  AddType application/x-httpd-php .php2
</IfModule>
Comment 1 Nalin Dahyabhai 2000-03-07 09:48:59 EST
This is the way the PHP team does it.  It might seem like a good idea to change
it, but changing this would make our setup incompatible with just about every
piece of documentation out there (the FAQ at http://www.php.net/FAQ.php3, to
name just one example).

Note You need to log in before you can comment on or make changes to this bug.