Bug 994018 - pam_mapi possibly affected by F-20 unversioned docdir change
pam_mapi possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam_mapi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
:
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 09:56 EDT by Ville Skyttä
Modified: 2013-08-06 13:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: pam_mapi-0.1.2-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 13:47:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 09:56:36 EDT
pam_mapi was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Robert Scheck 2013-08-06 10:03:19 EDT
Ville, which macro can be used across old and new behaviour? From what I get,
%_docdir_fmt can not be used directly in *.spec files. Is known how RHEL 7 is
going to behave regarding this? Will they also switch?
Comment 2 Ville Skyttä 2013-08-06 10:34:17 EDT
(In reply to Robert Scheck from comment #1)
> Ville, which macro can be used across old and new behaviour?

See first link in the initial comment, and the "Detailed Description" section in it. I'd imagine if you use plain %doc or %{_pkgdocdir} as suggested, you don't need to know what EL7 is going to do (I don't).
Comment 3 Robert Scheck 2013-08-06 13:47:25 EDT
Sorry, did not recognize the new %{_pkgdocdir} macro.

Note You need to log in before you can comment on or make changes to this bug.