Bug 994028 - [Doc] Clarify multi-tenant networking requirements.
[Doc] Clarify multi-tenant networking requirements.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Martin Lopes
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks: 1049118
  Show dependency treegraph
 
Reported: 2013-08-06 09:58 EDT by Stephen Gordon
Modified: 2016-04-26 15:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-09 23:36:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-08-06 09:58:39 EDT
Document URL: 

https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Installation_and_Configuration_Guide/chap-Installing_the_OpenStack_Networking_Service.html#Networking_Service_Requirements

Section Number and Name: 

Chapter 9. Installing the OpenStack Networking Service

Describe the issue: 

The guide as originally envisaged provides a very "open" view of the networking stack, attempting to support a range of different deployments from PoC (local) networking to multi-node and multi-tenant setups.

Suggestions for improvement: 

Clarify up from that multi-tenant networking requires VLANs.
Comment 2 Summer Long 2013-08-08 19:23:25 EDT
Steve, looks like you have an idea of the content for this? Do you need any more info to get going?
Comment 3 Perry Myers 2013-08-18 13:18:12 EDT
> Suggestions for improvement: 
> 
> Clarify up from that multi-tenant networking requires VLANs.

Or GRE/VXLAN tunnels.  We'll definitely have GRE tunnels in RHOS 4.0/RHEL 6.5.  VXLAN is likely but not certain yet.
Comment 4 Summer Long 2013-08-30 00:51:32 EDT
Also from Brent Holden on the dev mailing list (prompting this bug): 
Can the documentation be updated with a sample visual architecture? For example, if you server has 2 NICs, which side needs VLANs configured for tenant networks? What interfaces need to be bound to which bridges? There's no visual guide to help the user understand and it's difficult to wrap your head around some of the practical realities of how it would be setup. See this for an example: https://github.com/ansible/ansible-redhat-openstack/blob/master/README.md

A reference setup (with graphics) at the beginning of the quantum description would be immensely helpful. It's not clear until later that the setup requires GRE or VLANs to be useful for multi-tenants. For someone wading in to how to setup quantum, it's a painful experience that requires visits to websites and forums that mostly aren't our properties. This may come off as whiny but I'm trying to relate my experiences of getting quantum setup for our labs, which would likely closely mimic a customer's experience. 

I've put these here. If they are too big a task for the rework, will need to split off into separate bugs.
Comment 8 Martin Lopes 2015-03-09 23:36:06 EDT
This content was previously added.

Link: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html-single/Installation_and_Configuration_Guide/index.html#Configuring_Open_vSwitch_tunnels

Includes:
* Sample architecture diagram.
* Specific mention of VLANs role in multi-tenant networking.
* Describes how tunnels allows this functionality to span between nodes.
* Sample tunnel configuration steps.

Note You need to log in before you can comment on or make changes to this bug.