Bug 994039 - pidgin possibly affected by F-20 unversioned docdir change
pidgin possibly affected by F-20 unversioned docdir change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stu Tomlinson
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Changes...
: Reopened
Depends On:
Blocks: F20UnversionedDocDirs
  Show dependency treegraph
 
Reported: 2013-08-06 10:01 EDT by Ville Skyttä
Modified: 2013-08-08 09:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: pidgin-2.10.7-8.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 09:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-08-06 10:01:24 EDT
pidgin was identified as a package possibly needing maintainer attention
due to the F-20 unversioned doc dir change. The identification is not
foolproof, it is basically this grep:

    grep -E "(/doc|_docdir|_defaultdocdir).+version" *.spec

Please review your package and make the appropriate changes, if any. A
good starting point is checking the lines output by the above grep for
your specfile. For the vast majority of packages, after the changes,
the expected outcome is that documentation dirs in /usr/share/doc
should no longer contain the package version.

More information and tips:
  https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183943
  http://thread.gmane.org/gmane.linux.redhat.fedora.devel/183942/focus=183973
Comment 1 Jan Synacek 2013-08-08 08:50:56 EDT
The docdir is already unversioned, nothing needs any intervention.
Comment 2 Ville Skyttä 2013-08-08 09:00:25 EDT
...but examining the suggested grep output would have revealed this:

$ grep -A 1 -B 1 -E "(/doc|_docdir|_defaultdocdir).+version" pidgin.spec 
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/
ln -sf ../../doc/pidgin-docs-%{version}/html/ \
    $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/pidgin

Now that the docs are installed into an unversioned dir, that symlink is broken.
Comment 3 Jan Synacek 2013-08-08 09:56:27 EDT
Hmm, I completely oversaw that... It should be fixed now:

http://pkgs.fedoraproject.org/cgit/pidgin.git/commit/?id=ce71969dd2a5883dba76bf7292520c99814e46e9

Note You need to log in before you can comment on or make changes to this bug.