Bug 994044 - cli: --timeout should accept time specifiers
cli: --timeout should accept time specifiers
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
Tomas Dolezal
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 10:02 EDT by Tomas Dolezal
Modified: 2015-03-05 08:22 EST (History)
4 users (show)

See Also:
Fixed In Version: firewalld-0.3.9-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 08:22:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-08-06 10:02:46 EDT
Description of problem:
* --timeout should accept time specifiers like minute, hour, day or week

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1

How reproducible:
always

Steps to Reproduce:
firewall-cmd --add-service=http --timeout 4m

Expected results:
please fix or provide information why do you think it shouldn't be fixed this way
thanks

Additional info:
CCed affiliated users
Comment 3 Thomas Woerner 2013-08-06 11:50:57 EDT
The timeout is handled by firewalld and not by netfilter. firewalld removes all rules and netfilter helpers, that have been added to activate the feature with the timeout after it timed out.

If you enable for example port forwarding, this is more than one rule and depends also on the target (if it gets forwarded locally or not). netfilter is not able to handle this in a good and usable way.

The timeout is used in the same way in the command line client and also in the D-Bus interface: As a natural number. Allowing the use of other values than seconds in the command line client will not be doable with the current D-Bus interface.
Comment 4 Tomas Dolezal 2013-08-07 08:37:57 EDT
Isn't it possible to translate the value from e.g. hours to seconds before sending it over D-Bus?
If only seconds are possible, then user would need to use something like this:
firewall-cmd --add-service http --timeout $((4*60*60)) to achive 4h value.
Comment 5 Thomas Woerner 2013-11-12 07:23:35 EST
Moving to 7.1.
Comment 12 errata-xmlrpc 2015-03-05 08:22:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0520.html

Note You need to log in before you can comment on or make changes to this bug.