Bug 994134 - cli: direct rule: add examples and default table
cli: direct rule: add examples and default table
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 10:46 EDT by Tomas Dolezal
Modified: 2013-10-23 10:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 10:44:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-08-06 10:46:12 EDT
Description of problem:
cli: RFE direct rule: set "filter" table as default. in iptables it may be omitted because it defaults to it. firewalld should not ignore that.

manpage: add examples of direct rules (there isn't even one)

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1

How reproducible:
always

Steps to Reproduce:
works: firewall-cmd --direct --add-rule ipv4 filter INPUT 1 -s 192.168.253.253 -p tcp --dport 80 -j DROP
not work: firewall-cmd --direct --add-rule ipv4 INPUT 1 -s 192.168.253.253 -p tcp --dport 80 -j DROP


Expected results:
* direct rule without table specification defaults to "filter" table
* the rule may be shown and represented with it, the point is just to ease it for the user when configuring

Additional info:
Comment 3 Thomas Woerner 2013-10-23 10:44:07 EDT
The use of a default table for the direct interface will make parsing much more complicated and also ambiguous. This could end up in big problems.

Closing as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.