Bug 994146 - rich rules are ignored on trusted/blocked zone
rich rules are ignored on trusted/blocked zone
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 994144
  Show dependency treegraph
 
Reported: 2013-08-06 11:03 EDT by Tomas Dolezal
Modified: 2013-12-03 07:58 EST (History)
2 users (show)

See Also:
Fixed In Version: firewalld-0.3.8-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 994144
Environment:
Last Closed: 2013-12-03 07:57:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-08-06 11:03:07 EDT
+++ This bug was initially created as a clone of Bug #994144 +++

Description of problem:
rich rules are ignored on trusted and other former immutable zones

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1

How reproducible:
always

Steps to Reproduce:
1. firewall-cmd --list-all

Actual results #1:
trusted (default, active)
  interfaces: eth0
...
  rich rules: 
	rule service name="http" log level="info"

Actual results #2:
block (default, active)
  interfaces: eth0
  services: http bacula-client bacula
...
  rich rules: 
	rule service name="http" log level="info"

Expected results:
rich rules are working
or "add" command does not print "success" on its exit

Additional info:
Comment 1 Jiri Popelka 2013-12-03 07:57:13 EST
Should have been fixed since firewalld-0.3.8-1.fc19, see also bug #994144, commit #2.
Comment 2 Jiri Popelka 2013-12-03 07:58:40 EST
(In reply to Jiri Popelka from comment #1)
> ...see also bug #994144, commit #2.

bug #994144, comment #2  :-)

Note You need to log in before you can comment on or make changes to this bug.