Bug 994165 - rubygem-activesupport gemspec requires wrong i18n version
rubygem-activesupport gemspec requires wrong i18n version
Product: Fedora
Classification: Fedora
Component: rubygem-activesupport (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
Depends On:
Blocks: 993308
  Show dependency treegraph
Reported: 2013-08-06 11:48 EDT by Troy Dawson
Modified: 2013-08-12 15:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-12 15:48:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2013-08-06 11:48:13 EDT
Description of problem:
/usr/share/gems/specifications/activesupport-3.2.13.gemspec requires i18n = 0.6.1 but i18n 0.6.4 is what's available in rawhide

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run a test that depends on activesupport

Actual results:
/usr/share/rubygems/rubygems/specification.rb:2011:in `raise_if_conflicts': Unable to activate activesupport-3.2.13, because i18n-0.6.4 conflicts with i18n (= 0.6.1) (Gem::LoadError)

Expected results:
gems to load and do their job

Additional info:
A good way to test this is to try to build rubygem-origin on rawhide.  The %check section on it triggers the problem.
Comment 1 Troy Dawson 2013-08-12 15:48:46 EDT
Update to 4.0.0 fixed this.  Closing.

Note You need to log in before you can comment on or make changes to this bug.