Bug 994169 - yum install puppet pulls jruby instead of normal ruby, pulling in a gigantic tree
yum install puppet pulls jruby instead of normal ruby, pulling in a gigantic ...
Status: CLOSED DUPLICATE of bug 985208
Product: Fedora
Classification: Fedora
Component: puppet (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 11:56 EDT by Matthew Miller
Modified: 2013-08-06 12:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 12:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2013-08-06 11:56:34 EDT
Installing puppet on the Fedora 19 cloud image pulls in over 100 new packages, and uses 200MB on disk. Is there any reasonable way to reduce this?

Installing:
 puppet                              noarch            3.1.1-5.fc19                                  updates            901 k
Installing for dependencies:
 alsa-lib                            x86_64            1.0.27.2-1.fc19                               updates            385 k
 apache-commons-cli                  noarch            1.2-9.fc19                                    fedora              50 k
 apache-commons-logging              noarch            1.1.2-2.fc19                                  fedora              75 k
 augeas-libs                         x86_64            1.1.0-1.fc19                                  updates            320 k
 bouncycastle                        noarch            1.46-7.fc19                                   fedora             2.4 M
 bouncycastle-mail                   noarch            1.46-7.fc19                                   fedora             567 k
 bsf                                 noarch            2.4.0-16.fc19                                 fedora             105 k
 bytelist                            noarch            1.0.8-5.fc19                                  fedora              15 k
 cal10n                              noarch            0.7.7-1.fc19                                  fedora              35 k
 eclipse-equinox-osgi                x86_64            1:4.3.0-2.fc19                                updates            1.3 M
 facter                              x86_64            1.6.18-4.fc19                                 updates             62 k
 felix-osgi-core                     noarch            1.4.0-12.fc19                                 fedora              94 k
 flac-libs                           x86_64            1.3.0-2.fc19                                  fedora             169 k
 fontconfig                          x86_64            2.10.93-1.fc19                                fedora             224 k
 fontpackages-filesystem             noarch            1.44-7.fc19                                   fedora             9.8 k
 geronimo-jms                        noarch            1.1.1-16.fc19                                 fedora              31 k
 giflib                              x86_64            4.1.6-7.fc19                                  fedora              39 k
 gsm                                 x86_64            1.0.13-9.fc19                                 fedora              29 k
 hawtjni                             noarch            1.6-4.fc19                                    fedora             146 k
 hiera                               noarch            1.0.0-5.fc19                                  fedora              22 k
 hwdata                              noarch            0.249-1.fc19                                  updates            1.1 M
 invokebinder                        noarch            1.1-4.fc19                                    fedora              29 k
 jaffl                               noarch            0.5.9-5.fc19                                  fedora             219 k
 jansi                               noarch            1.9-3.fc19                                    fedora              43 k
 jansi-native                        x86_64            1.4-5.fc19                                    fedora              43 k
 java-1.7.0-openjdk                  x86_64            1:1.7.0.25-2.3.12.3.fc19                      updates             25 M
 java-1.7.0-openjdk-devel            x86_64            1:1.7.0.25-2.3.12.3.fc19                      updates            9.1 M
 javamail                            noarch            1.4.3-16.fc19                                 fedora             455 k
 javapackages-tools                  noarch            0.15.0-2.fc19                                 updates             27 k
 jcodings                            noarch            1.0.9-1.fc19                                  fedora             1.1 M
 jffi                                x86_64            1.2.6-1.fc19                                  fedora             261 k
 jline                               noarch            1.0-4.fc19                                    fedora              68 k
 jline2                              noarch            2.10-6.fc19                                   fedora             112 k
 jna                                 x86_64            3.5.0-2.fc19                                  fedora             771 k
 jnr-constants                       noarch            0.8.4-2.fc19                                  fedora             286 k
 jnr-enxio                           noarch            0.3-3.fc19                                    fedora              35 k
 jnr-ffi                             noarch            0.7.10-2.fc19                                 fedora             369 k
 jnr-netdb                           noarch            1.0.1-7.fc18                                  fedora              47 k
 jnr-posix                           noarch            2.4.0-1.fc19                                  fedora             146 k
 jnr-unixsocket                      noarch            0.2-1.fc19                                    fedora              24 k
 jnr-x86asm                          noarch            1.0.2-1.fc19                                  fedora             194 k
 joda-convert                        noarch            1.3-1.fc19                                    fedora              45 k
 joda-time                           noarch            2.2-1.tzdata2013c.fc19                        fedora             486 k
 joni                                noarch            1.1.9-1.fc19                                  fedora             180 k
 jpackage-utils                      noarch            1.7.5-27.fc19                                 updates             63 k
 jruby                               noarch            1.7.2-1.fc19                                  fedora              11 M
 jruby-yecht                         noarch            1.7.2-1.fc19                                  fedora              72 k
 jzlib                               noarch            1.1.1-3.fc19                                  fedora              72 k
 libICE                              x86_64            1.0.8-5.fc19                                  fedora              62 k
 libSM                               x86_64            1.2.1-5.fc19                                  fedora              37 k
 libX11                              x86_64            1.6.0-1.fc19                                  updates            594 k
 libX11-common                       noarch            1.6.0-1.fc19                                  updates            181 k
 libXau                              x86_64            1.0.8-1.fc19                                  fedora              29 k
 libXext                             x86_64            1.3.2-1.fc19                                  fedora              37 k
 libXfont                            x86_64            1.4.5-4.fc19                                  fedora             139 k
 libXi                               x86_64            1.7.2-1.fc19                                  updates             38 k
 libXrender                          x86_64            0.9.7-6.20130524git786f78fd8.fc19             fedora              25 k
 libXtst                             x86_64            1.2.2-1.fc19                                  fedora              20 k
 libasyncns                          x86_64            0.8-5.fc19                                    fedora              26 k
 libfontenc                          x86_64            1.1.1-3.fc19                                  fedora              28 k
 libogg                              x86_64            2:1.3.0-5.fc19                                fedora              24 k
 libpng                              x86_64            2:1.5.13-2.fc19                               fedora             210 k
 libselinux-ruby                     x86_64            2.1.13-15.fc19                                fedora             123 k
 libsndfile                          x86_64            1.0.25-7.fc19                                 fedora             149 k
 libvorbis                           x86_64            1:1.3.3-4.fc19                                fedora             203 k
 libxcb                              x86_64            1.9-3.fc19                                    fedora             160 k
 libxslt                             x86_64            1.1.28-3.fc19                                 fedora             240 k
 log4j                               noarch            1.2.17-10.fc19                                fedora             448 k
 nailgun                             x86_64            0.7.1-7.fc19                                  fedora              35 k
 objectweb-asm                       noarch            3.3.1-7.fc19                                  fedora             196 k
 objectweb-asm4                      noarch            4.1-3.fc19                                    fedora             206 k
 pciutils                            x86_64            3.2.0-2.fc19                                  fedora              89 k
 pciutils-libs                       x86_64            3.2.0-2.fc19                                  fedora              44 k
 pulseaudio-libs                     x86_64            3.0-10.fc19                                   fedora             482 k
 rhino                               noarch            1.7R4-4.fc19                                  updates            1.0 M
 ruby                                x86_64            2.0.0.247-14.fc19                             updates             65 k
 ruby-augeas                         x86_64            0.5.0-1.fc19                                  fedora              23 k
 ruby-irb                            noarch            2.0.0.247-14.fc19                             updates             86 k
 ruby-libs                           x86_64            2.0.0.247-14.fc19                             updates            2.8 M
 ruby-shadow                         x86_64            1.4.1-19.fc19                                 fedora              13 k
 rubygem-bigdecimal                  x86_64            1.2.0-14.fc19                                 updates             77 k
 rubygem-io-console                  x86_64            0.4.2-14.fc19                                 updates             48 k
 rubygem-json                        x86_64            1.7.7-100.fc19                                fedora              60 k
 rubygem-psych                       x86_64            2.0.0-14.fc19                                 updates             74 k
 rubygem-rdoc                        noarch            4.0.1-1.fc19                                  fedora             288 k
 rubygems                            noarch            2.0.5-100.fc19                                updates            206 k
 rubypick                            noarch            1.1.0-1.fc19                                  fedora             6.1 k
 slf4j                               noarch            1.7.4-1.fc19                                  fedora             172 k
 snakeyaml                           noarch            1.11-4.fc19                                   fedora             241 k
 ttmkfdir                            x86_64            3.0.9-39.fc19                                 fedora              46 k
 tzdata-java                         noarch            2013c-2.fc19                                  updates            158 k
 virt-what                           x86_64            1.12-3.fc19                                   fedora              25 k
 which                               x86_64            2.20-5.fc19                                   fedora              41 k
 xalan-j2                            noarch            2.7.1-19.fc19                                 updates            1.9 M
 xbean                               noarch            3.13-1.fc19                                   fedora             379 k
 xerces-j2                           noarch            2.11.0-14.fc19                                fedora             1.1 M
 xml-commons-apis                    noarch            1.4.01-12.fc19                                fedora             227 k
 xml-commons-resolver                noarch            1.2-12.fc19                                   fedora             108 k
 xorg-x11-font-utils                 x86_64            1:7.5-17.fc19                                 updates             86 k
 xorg-x11-fonts-Type1                noarch            7.5-8.fc19                                    fedora             521 k
 yecht                               noarch            0.0.2-8.fc19                                  fedora              90 k
 yydebug                             noarch            1.1.0-9.fc19                                  fedora              24 k

Transaction Summary
==============================================================================================================================
Install  1 Package (+102 Dependent packages)

Total download size: 72 M
Installed size: 200 M
Is this ok [y/d/N]:


On $POPULAR_OTHER_DISTRO, this looks like

The following extra packages will be installed:
  augeas-lenses debconf-utils facter libaugeas-ruby1.8 libaugeas0 libruby1.8 ruby-shadow ruby1.8
Suggested packages:
  augeas-doc ruby-json augeas-tools ruby-selinux librrd-ruby1.8 ruby1.8-examples ri1.8 ruby-switch
The following NEW packages will be installed:
  augeas-lenses debconf-utils facter libaugeas-ruby1.8 libaugeas0 libruby1.8 puppet-common ruby-shadow ruby1.8
0 upgraded, 9 newly installed, 0 to remove and 18 not upgraded.
Need to get 3,185 kB of archives.
After this operation, 12.2 MB of additional disk space will be used.
Comment 1 Matthew Miller 2013-08-06 11:59:43 EDT
Bill Nottingham points out that the problem is that yum is selecting jruby as the ruby interpretter. If I install ruby first manually, everything becomes much more reasonable. (10 ruby packages = 13M, + 11 other dependencies = 8.8M.
Comment 2 Matthew Miller 2013-08-06 12:02:32 EDT

*** This bug has been marked as a duplicate of bug 985208 ***
Comment 3 Sam Kottler 2013-08-06 12:03:54 EDT
Yep, this is a known issue that was fixed in F19/rawhide in the -5 release on 3.1.1. I haven't tested recently on rawhide because installation was broken for a while, but I will soon.

IMO there is a bigger bug here than just what's happening with Puppet. JRuby should never be selected over MRI, it's not compatible completely. I will talk with the jruby maintainers and figure out which other packages this affects.

Note You need to log in before you can comment on or make changes to this bug.