Bug 99418 - kernel upgrading to 2.6.0-0 test
kernel upgrading to 2.6.0-0 test
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-18 16:56 EDT by Andy_M
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 03:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy_M 2003-07-18 16:56:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
not usb keyboard and mouse could be used after upgrading from 2.4.20 to 2.6.0
kernel version.

Version-Release number of selected component (if applicable):
kernel upgrading to 2.6.0-0 test

How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
    

Additional info:
Comment 1 Eric Bursley 2003-07-19 13:33:41 EDT
I saw a very simular event after installing the new 2.6.0-0 test kernel.  I also
noticed named complaining when the service started up:
process `named' is using obsolete setsockopt SO_BSDCOMPAT
process `named' is using obsolete setsockopt SO_BSDCOMPAT
process `named' is using obsolete setsockopt SO_BSDCOMPAT
process `named' is using obsolete setsockopt SO_BSDCOMPAT
process `named' is using obsolete setsockopt SO_BSDCOMPAT
process `named' is using obsolete setsockopt SO_BSDCOMPAT
Comment 2 Rik van Riel 2003-07-19 14:40:39 EDT
the named error messages are a problem with bind, "setsockopt SO_BSDCOMPAT" has
been obsolete since kernel version 2.2 or so and does nothing (I think Linux
sockets are already BSD compatible); the 2.6 kernel simply prints an error
message to catch those last few applications using this interface (which has
been obsolete for more than 6 years)

Andy_M's problem does look genuine, though...
Comment 3 Eric Bursley 2003-07-19 18:41:03 EDT
Should I open a new bug regarding the named problem then?  I am using the
standard bind packages from RH 9.
Comment 4 Arjan van de Ven 2003-07-19 18:45:22 EDT
yes please do a separate bug for named.

the usb issue can be that the usb modules got renamed between 2.4 and 2.6;
we're working on making modutils autoconvert but it currently doesn't.

the new name is uhci-hcd.ko while modutils probably tries to load uchi.ko
renaming or making a symlink should show if this assumption of "different module
name" is correct or not.
Comment 5 Alan Cramer 2003-07-20 12:36:40 EDT
mine tends to tell me that usb-ochi module could not be found.  would this be
linked to modules.conf or rc.sysinit?
Comment 6 Alan Cramer 2003-07-20 22:58:25 EDT
tried again with kernel-2.6.0-0.test1.1.26 and got the same error above
(couldn't find usb_ochi.ko ) and i also got told this time that mousedev was
already in the kernel.
Comment 7 Alan Cramer 2003-07-31 01:52:10 EDT
no usb mouse and same problem with usb-ochi in kernel-2.6.0-0.test2.1.28.  is
there something i am not doing that i should be?
Comment 8 Alan Cramer 2003-08-04 13:39:58 EDT
Upgraded to kernel-2.6.0-0.test2.1.29

Upon booting, it complains about usb-ochi as usual.

This time however instead of complaining about mousedev and keybdev already
being in the kernel, it now says that it couldn't be found.

once i got into X, i switched to a new console via Ctrl+Alt+F1, logged in as
root and invoked modprobe ochi-hcd and it worked for the first time, and now the
mouse is working.

Just need to fix it during boot somehow.  If someone can point me to the right
place, I should be able to fix it myself.
Comment 9 Eric Bursley 2003-08-04 20:55:50 EDT
I also can not view the RPM database, or install any RPM when booted into the 
2.6.0 kernel.  I get the following:
[root@badboy root]# rpm -qa | grep kernel
rpmdb: unable to join the environment
error: db4 error(11) from dbenv->open: Resource temporarily unavailable
error: cannot open Packages index using db3 - Resource temporarily unavailable 
(11)
error: cannot open Packages database in /var/lib/rpm
[root@badboy root]#
---------

Rebooting into the 2.4.20-13.9 allows RPM to work normally
Comment 10 Arjan van de Ven 2003-08-05 04:23:19 EDT
the later is an RPM bug.... known.
Comment 11 Bill Nottingham 2004-01-28 03:57:31 EST
The usb stuff should be more or less all taken care of with current
kernels + modutils. Please file other bugs separately, thanks!

Note You need to log in before you can comment on or make changes to this bug.