This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 994186 - fence_scsi does not work with pacemaker
fence_scsi does not work with pacemaker
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 987355 994466
  Show dependency treegraph
 
Reported: 2013-08-06 12:52 EDT by Jaroslav Kortus
Modified: 2013-11-21 02:19 EST (History)
4 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-32.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994466 (view as bug list)
Environment:
Last Closed: 2013-11-21 02:19:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Kortus 2013-08-06 12:52:36 EDT
Description of problem:
It's not possible to add fence_scsi as a stonith device in pacemaker:
# pcs stonith describe fence_scsi
Stonith options for: fence_scsi
Traceback (most recent call last):
  File "/usr/sbin/pcs", line 110, in <module>
    main(sys.argv[1:])
  File "/usr/sbin/pcs", line 96, in main
    stonith.stonith_cmd(argv)
  File "/usr/lib/python2.6/site-packages/pcs/stonith.py", line 24, in stonith_cmd
    stonith_list_options(argv[0])
  File "/usr/lib/python2.6/site-packages/pcs/stonith.py", line 125, in stonith_list_options
    dom = parseString(metadata)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/dom/minidom.py", line 1925, in parseString
    return expatbuilder.parseString(string)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/dom/expatbuilder.py", line 942, in parseString
    return builder.parseString(string)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/dom/expatbuilder.py", line 223, in parseString
    parser.Parse(string, True)
xml.parsers.expat.ExpatError: mismatched tag: line 20, column 3

The same error repeats when you do pcs stonith create.

I'd also like to raise a question how unfencing should be done with pacemaker and fence_scsi. In cluster.conf we had <unfence> tags for this. I'm unable to find any useful pointer to how this is handled in pacemaker cluster.

Version-Release number of selected component (if applicable):
fence-agents-3.1.5-31.el6.x86_64
pcs-0.9.59-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. pcs stonith describe fence_scsi
2.
3.

Actual results:
traceback

Expected results:
no traceback on any valid operation (describe, create among others)

Additional info:
Comment 3 Marek Grac 2013-08-07 06:54:35 EDT
Fixed in upstream:

https://git.fedorahosted.org/cgit/fence-agents.git/commit/?id=e9bc1315a72217712cf0b8d27733d1e103a264ee


Unit test results:

[root@sparta ~]# pcs stonith describe fence_scsi
Stonith options for: fence_scsi
  aptpl: Use APTPL flag for registrations
  devices: List of devices to be used for fencing action
  logfile: File to write error/debug messages
  delay: Wait X seconds before fencing is started
  key: Key value to be used for fencing action
  action: Fencing action
  nodename: Name of node
Comment 6 errata-xmlrpc 2013-11-21 02:19:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1562.html

Note You need to log in before you can comment on or make changes to this bug.