Bug 994188 - Reboot after install often delays for ~1 minute
Reboot after install often delays for ~1 minute
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
All All
unspecified Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On: 974383
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 13:01 EDT by Brian Lane
Modified: 2014-06-17 21:35 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-19.31.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 974383
Environment:
Last Closed: 2014-06-13 05:17:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-08-06 13:01:03 EDT
+++ This bug was initially created as a clone of Bug #974383 +++

At least Kamil and I have been seeing this throughout Fedora 19 testing, but never got around to filing a bug on it.

When you finish installation there's a button to reboot. Often, when you click it, the system delays, sitting at a console with some irrelevant info on it, for about a minute (for me) before restarting. (For a long time I just thought it was broken, and forced shutdown on my test VMs at that point). I don't know if it's 1 minute or longer for Kamil. I think other testers have mentioned seeing this too.

bcl thinks this is probably a systemd thing, at least as a first guess. We'll try and provide some more detailed info later, I just wanted to get the bug filed before I forgot about it again.
Comment 1 Brian Lane 2013-08-06 13:03:11 EDT
Found the problem, patch posted to anaconda-patches. Amount to not using os.system to call systemctl for shutdown since it blocks.
Comment 2 Harald Hoyer 2013-08-07 06:34:44 EDT
or use the "--no-block" option of systemctl
Comment 3 Brian Lane 2013-12-11 13:22:20 EST
upstream commit a62114fdc8133fecc401351659c604df3a1e73dc
Comment 5 Michal Kovarik 2014-02-11 12:20:47 EST
System is rebooted almost immediately with anaconda-19.31.56-1.el7. Moving to Verified.
Comment 6 Ludek Smid 2014-06-13 05:17:39 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.