Bug 9942 - Samba / LinuxConf / inetd - Dependency Problem
Samba / LinuxConf / inetd - Dependency Problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-03 15:31 EST by Don Head
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 16:15:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Head 2000-03-03 15:31:55 EST
1)  Samba adds the "swat" service to /etc/inetd.conf without checking if
the inetd package (netkit-base) is installed.  This gives the user the
false impression that "swat" should be working.

Samba should have netkit-base as a dependency.  Anyone not wanting
netkit-base, and therefore the swat service, can use --nodeps to override.


2)  LinuxConf adds the "linuxconf" service to /etc/inetd.conf without
checking if the inetd package (netkit-base) is installed.  This gives the
user the false impression that "linuxconf" should be working.

LinuxConf should have netkit-base as a dependency.  Anyone not wanting
netkit-base, and therefore the "linuxconf" service, can use --nodeps to
override.


3)  The inetd package (netkit-base) installs without merging changes with
the existing /etc/inetd.conf.  If it does not find one, it creates it with
the default services.  If it finds one, it creates an inetd.rpmsave.  If
for some reason LinuxConf or Samba are installed before netkit-base, the
only two services that will be active are "linuxconf" and "swat", because
netkit-base will see an existing inetd.conf and not overwrite it.  This
means that telnet and FTP are not working.

The inetd package (netkit-base) should do some inet.conf checking upon
installation, rather than the "all or nothing" approach.


Note)  This was noticed in Red Hat 6.1.

I do not have permission to use the person's name who found this.  If she
wants credit, I'm more than happy to give it to her.  She did find it, I
just verified it and reported it.

Don Head
Linux Mentor
Wave Technologies, Inc.
dhead@wavetech.com
Comment 1 Trond Eivind Glomsrxd 2001-01-19 16:17:30 EST
Red Hat Linux 7 uses xinetd, where each service has its own configuration file.
This solves the above problem.

Note You need to log in before you can comment on or make changes to this bug.