Bug 994206 - virt-manager doesn't save preferences
virt-manager doesn't save preferences
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 14:00 EDT by Tomas Smetana
Modified: 2013-08-14 20:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 20:09:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "virt-manager --debug" (10.03 KB, text/plain)
2013-08-08 23:53 EDT, Tomas Smetana
no flags Details

  None (edit)
Description Tomas Smetana 2013-08-06 14:00:44 EDT
Description of problem:
Any change in the virt-manager's preferences gets lost after virt-manager exits.

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start virt-manager
2. Go to "Edit"->"Preferences"
3. Change some setting (e.g. check "Enable system tray icon" or change the default storage format...)
4. Exit virt-manager
5. Start it again and take a look at the preferences

Actual results:
All the changes are lost

Expected results:
The changes remain persistent
Comment 1 Cole Robinson 2013-08-06 14:42:06 EDT
Things work fine for me.

If you run virt-manager --debug and try to reproduce, do you see any error messages or backtraces? What desktop environment are you using?
Comment 2 Tomas Smetana 2013-08-08 23:53:17 EDT
Created attachment 784714 [details]
Output of "virt-manager --debug"

This shows where the problem is:
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

Looks like GSettings requires dconf to be installed but doesn't require it.  I suppose this happens in the non-Gnome environments only -- I'm using Xfce.

Thanks for the hint about the debugging output.

I suppose this is NOTABUG from the virt-manager's perspective unless you decide to add hard requirement on the dconf to ensure the settings work as expected.  Up to you.
Comment 3 Cole Robinson 2013-08-14 20:09:14 EDT
Thanks for the info. Weird that gsettings has that fallback but presumably there's a reason. Other gnome apps don't have a Require on dconf so virt-manager likely shouldn't either. Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.