Bug 994307 - pip should install to a separate space than standard packages
pip should install to a separate space than standard packages
Status: CLOSED DUPLICATE of bug 662034
Product: Fedora
Classification: Fedora
Component: python-pip (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Flink
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 22:56 EDT by Pádraig Brady
Modified: 2016-01-04 09:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 11:30:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2013-08-06 22:56:03 EDT
pip is a separate system to rpm, and it's strange and problematic to have pip install python projects to the standard package space.

debian for example does it correctly IMHO by installing to /usr/local/lib/python2.7/site-packages/ rather than /usr/lib/python2.7/site-packages/

Perhaps python would need to be modified also to add /usr/local/...
to the sys.path _before_ /usr/...

Please see here for some issues in having these conflicting areas:
http://lists.openstack.org/pipermail/openstack-dev/2013-August/013039.html
Comment 1 Pádraig Brady 2013-08-07 07:47:26 EDT
Some more example awkwardness due to this issue:
https://review.openstack.org/#/c/39862/
Comment 2 Alan Pevec 2013-08-07 09:45:38 EDT
Duplicate of bug 662034 ?
Comment 3 Pádraig Brady 2013-08-07 11:30:01 EDT
Yep good spot.
This aspect is best summarised in bug 662034#c8

*** This bug has been marked as a duplicate of bug 662034 ***

Note You need to log in before you can comment on or make changes to this bug.