Bug 994403 - All options “Create Snapshot“ during VM “In Preview” status, should be grayed out
All options “Create Snapshot“ during VM “In Preview” status, should be grayed...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
low Severity low
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Arik
sefi litmanovich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 04:26 EDT by vvyazmin@redhat.com
Modified: 2016-08-23 16:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:20:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (4.00 MB, application/x-gzip)
2013-08-07 04:26 EDT, vvyazmin@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45780 master MERGED core: indication for snapshot preview in vm Never
oVirt gerrit 45782 master MERGED webadmin: disable snapshot creation when preview snapshot Never

  None (edit)
Description vvyazmin@redhat.com 2013-08-07 04:26:28 EDT
Created attachment 783730 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
All options “Create Snapshot“ during VM “In Preview” status, should be grayed out

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS8 environment:

RHEVM:  rhevm-3.3.0-0.13.master.el6ev.noarch
VDSM:  vdsm-4.12.0-rc3.13.git06ed3cc.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK:  sanlock-2.6-2.el6.x86_64
PythonSDK:  rhevm-sdk-python-3.3.0.8-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
Create VM with one or multiple disk
Create Snapshots
Enter in “In Preview” status

Actual results:
Option “Create Snapshot” from right click on relevant VM --> stay active (not grayed out)
Option “Create Snapshot”(from main toolbar) on “Virtual Machines” main-tab --> stay active (not grayed out)
Option “Create” on sub-tub “Snapshots” in “Details Pane” --> grayed out

See attached print screen

Expected results:
All option should be grayed out

Impact on user:
none

Workaround:
none

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 3 Michal Skrivanek 2014-08-22 09:01:38 EDT
this bug won't fit into 3.5 release and is being deferred to a later release. If you deeply care about this bug and deserves to be re-evaluated please let me know
Comment 4 Michal Skrivanek 2015-10-23 09:55:23 EDT
missed 3.6 branch, targeting for next release, all done
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-16 09:11:13 EST
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.
Comment 6 sefi litmanovich 2015-12-10 06:31:56 EST
Verified on rhevm-3.6.1.2-0.1.el6 but not 100% this was the intended behaviour:

1. Create vm with disk.
2. Create snapshot.
3. stop vm.
4. preview snapshot

Result:
1. create snapshot under Vm->Snapshots sub tab is grayed out.
2. right click on vm -> create snapshot isn't grayed out but in create snapshot menu the following message is marked: "Snapshot cannot be created since the VM is previewing a Snapshot." and no disks appear in the menu.
3. main "Virtual Machines" tab -> upper bar -> create snapshot isn't grayed out as well with the same behaviour as in (2).

I am verifying but Needinfoing to make sure this is what we expect and want, as in the description the requested behaviour is that all create snapshot options will be grayed out.
Comment 7 Arik 2015-12-10 06:56:19 EST
(In reply to sefi litmanovich from comment #6)
> I am verifying but Needinfoing to make sure this is what we expect and want,
> as in the description the requested behaviour is that all create snapshot
> options will be grayed out.

All options should be grayed out.
The fix was not backported to 3.6 (see comment 4).
Moving back to modify.
Comment 8 Michal Skrivanek 2015-12-10 07:30:39 EST
sorry, the rules moved it to ON_QA due to my mistake of not clearing one of the fields (flags) for 4.0, then the bot turned it into something else completely.
The fact that the bot moves the bug is causing more issues than benefits
Comment 10 sefi litmanovich 2016-04-06 11:21:57 EDT
Verified according to steps in description and commnet#6 with:
ovirt-engine-4.0.0-0.0.master.20160405102116.git3819ab7.el7.centos.noarch on rhel 7.2.
HOST:
Rhel 7.2
vdsm-4.17.999-883.git1c06132.el7.centos.noarch
libvirt-client-1.2.17-13.el7_2.4.x86_64

Create Snapshot option is greyed out in all cases while snapshot is in preview.
Comment 13 errata-xmlrpc 2016-08-23 16:20:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.