Bug 994407 - Virtio SCSI driver not working for Windows 2003
Virtio SCSI driver not working for Windows 2003
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Lev Veyde
Pavel Stehlik
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 04:32 EDT by Dušan Kajan
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 05:28:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dušan Kajan 2013-08-07 04:32:20 EDT
Description of problem:
The Virtio SCSI driver is installed (and correctly reported via Guest Agent), but after adding new Virtio SCSI disk, this disk is still not seen by Windows 2003 machine

Version-Release number of selected component (if applicable):
is8

How reproducible:
100%

Steps to Reproduce:
1. Have VM with Windows Server 2003 R2 64 bit
2. Install Guest Tools using installer
3. Shutdown VM and add new Virtion SCSI disk
4. Start VM, run Disk Management

Actual results:
the disk is still invisible to the VM

Expected results:
the disk should be visible
Comment 1 Itamar Heim 2013-08-09 10:41:32 EDT
version of the driver?
Comment 2 Itamar Heim 2013-08-12 00:07:49 EDT
lev - did you see something similar? is it an install issue or should be moved to kvm group?
Comment 3 Lev Veyde 2013-08-12 06:03:54 EDT
(In reply to Itamar Heim from comment #2)
> lev - did you see something similar? is it an install issue or should be
> moved to kvm group?

I tested it with Windows Server 2003 R2 Standard 64 bit (Build 3790.srv03_sp2_rtm.070216-1710 : Service Pack 2) , and I had no issues with either installing the driver as part of the Windows Guest Tools, or having a new drive being recognized.

As matter of fact I was even able to add a new disk while the OS was up and running, even though the recognition of the new disk is not instant like it normally happens under Windows 7 for instance, but takes about a minute to become recognizable to OS (through Rescan Disks of Disk Management).

Dusan:

Even without any Virtio-SCSI drives attached to the VM, the Virtio-SCSI Controller should be visible to the OS, as the device is normally created for all VMs under RHEV 3.3.

Before the driver installation it appears as SCSI Controller, and after the driver is properly installed it must appear as Red Hat VirtIO SCSI pass-through controller, under SCSI and RAID controllers in Device Manager.

Do you see it there ? Does it have a properly installed driver ?
Comment 4 Dušan Kajan 2013-10-22 11:58:43 EDT
wasnt able to reproduce on the newest is, marking as not a bug to avoid confusion

Note You need to log in before you can comment on or make changes to this bug.