Bug 994408 - jBPM engine does not support boundary event on Service Task
jBPM engine does not support boundary event on Service Task
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 04:39 EDT by Radovan Synek
Modified: 2014-08-06 16:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
service task process (10.37 KB, application/xml)
2013-08-07 04:39 EDT, Radovan Synek
no flags Details
script task process (9.73 KB, application/xml)
2013-08-07 04:39 EDT, Radovan Synek
no flags Details
full stacktrace (4.04 KB, text/x-log)
2013-08-07 04:40 EDT, Radovan Synek
no flags Details
boundary on script task (18.59 KB, image/png)
2013-09-30 12:31 EDT, Tihomir Surdilovic
no flags Details
screenshot (62.63 KB, image/png)
2013-10-01 04:11 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-07 04:39:22 EDT
Created attachment 783739 [details]
service task process

Take a look at attached process definitions - simple scenario with script task or service task. Both definitions were validated in jBPM Designer, but engine throws an exception when trying to build these definitions:
java.lang.IllegalArgumentException: Boundary events are supported only on StateBasedNode, found node: org.jbpm.workflow.core.node.ActionNode
(attaching full stacktrace)

These are valid bpmn2 definitions.

version: community 6.0.0.CR1
Comment 1 Radovan Synek 2013-08-07 04:39:58 EDT
Created attachment 783741 [details]
script task process
Comment 2 Radovan Synek 2013-08-07 04:40:31 EDT
Created attachment 783743 [details]
full stacktrace
Comment 3 Kris Verlaenen 2013-08-07 10:43:26 EDT
Boundary events on nodes that aren't state-based is indeed not supported, since these nodes are executed immediately, so it's unlikely adding a boundary event would be useful.

Would it be ok if we just prevent users from doing this then (or add validation messages) instead?
Comment 4 Kris Verlaenen 2013-08-07 11:57:13 EDT
The previous remark was for the script task only (where boundary events are not supported).

Boundary events for service tasks should be, so will look into this.

@Maciej, please take a look at the service task example, and if fixed assign to tiho for improving the validation in designer.
Comment 5 Maciej Swiderski 2013-08-07 12:24:58 EDT
service task does work as expected with boundary events. Script task as Kris described should not have boundary event attached as there will not be a way to call them.

Transferring that to Tihomir to prevent adding boundary events on Script Tasks.
Comment 6 Tihomir Surdilovic 2013-08-28 20:53:26 EDT
Fixed in master and 6.0.x branch of designer - boundary events are no longer attachable to script tasks.
Comment 7 Radovan Synek 2013-09-18 08:50:36 EDT
I was able to import the definition (script task process attachment) where the script task has the boundary event without any validation error. I was also able to create the same definition in jBPM Designer - I managed to attach boundary event to script task without any problem and again - no validation error.

Tiho, could you please provide the commit with the fix? It behaves like the fix wasn't included.
Comment 8 Tihomir Surdilovic 2013-09-30 12:31:45 EDT
Created attachment 805364 [details]
boundary on script task
Comment 9 Tihomir Surdilovic 2013-09-30 12:32:54 EDT
Not sure what could be going on. I tested with 6.0.x and its fine (see attached png).
Maybe try to clear your browser cache and test again. Let me know if issue is still there.
Comment 10 Radovan Synek 2013-10-01 04:11:17 EDT
Created attachment 805755 [details]
screenshot

Hello Tiho,

I cleared browser cache, also tried on different laptop - the behaviour is like this: boundary event cannot be attached when the event is being dragged from canvas. However, when I drag it directly from Object library panel to the script task, the boundary event can be attached.
Comment 14 Tihomir Surdilovic 2013-11-12 15:26:44 EST
could you please test again. i am not able to reproduce this issue. please try with latest. thanks
Comment 15 Radovan Synek 2013-11-13 02:30:16 EST
Hi Tiho,
I retested with org.kie:kie-wb-distribution-wars:6.0.0.Final:eap-6_1, is it the latest version you mentioned? I saw the same issue - boundary event can be attached on script task when it has been dragged directly from Object Library panel.
Comment 16 Tihomir Surdilovic 2013-11-13 19:02:55 EST
fixed in designer master and 6.0.x branches
Comment 17 Radovan Synek 2013-12-03 09:55:53 EST
Verified on BPMS-6.0.0.ER5
Comment 18 Radovan Synek 2014-03-18 10:37:05 EDT
qe_test_coverage:covered by community unit tests

Note You need to log in before you can comment on or make changes to this bug.