Bug 99441 - RH 8 & 9 Installers crashes before media check
RH 8 & 9 Installers crashes before media check
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-07-19 13:11 EDT by Erik
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-25 12:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Erik 2003-07-19 13:11:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 7.11  [en]

Description of problem:
Both red hat 8 and 9 failed to install on a 1.1Ghz athlon Compaq PC and 1.8Ghz 
Athlon XP-M HP laptop.  Both crashed just when asking if it should perform the 
media check; not even control-alt-delete affected them.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start computer with installer cd insterted
2.Tell installer to install
3.Wait for loading

Actual Results:  Both of my sytems become completely non-responsive, only the 
power button ends the freeze.  The system is asking if I want to perform the 
media check, but it doesn't respond to the arrows, tab, enter or any other keys. 
 I let the PC sit for over half an hour to see if it was a loading problem.

Expected Results:  The install should continue normally, allow the media check, 
and otherwise install the program.

Additional info:

Originally, I was trying to dual boot with win2K on the PC and winXP on the 
laptop, and that those windows were already installed.  I have created extra 
partitions for linux.  I used the same red hat CDs on a pentium pro system with 
no errors.  I tried putting the pentium pro system's hard drive in my athlon PC 
and it still didn't work.  I tried putting the CD in my athlon PC's DVD-rom and 
CD-RW, but neither worked.  I tried booting from the install floppy with no 
success.  I tried text install, expert install, installing with various 
combinations of options, installing with no options, and it always hangs just 
after loading something like ochi386 drivers (I can't really read it in the time 
it shows it).

There are no error messages, no error dumps, no new files on the hard drive.  I 
had the pentium system run the media check on all the CDs and It said they were 
good.  I don't know everything about my hardware, but here's what I know:

System 1:  Compaq Presario 7000 series, Athlon based PC (Crashed)
Athlon T-Bird running at 1.1Ghz (manufacturer setting)
512MB of SDRam on 3 sticks (128+128+256), PC100
80GB Maxor hard drive with 2 partions, a Win2K using NTFS and an empty fat32
8X-DVD Compaq ROM drive (might be 24X with CDs), Also LG 12x4x32 CD-RW
TNT2 Compaq edition AGP video card, 32MB SDram.

System 2:  HP Pavilion ze4300 series, Athlon based notebook (Crashed)
Athlon XP-M 2400+ running at 1.8Ghz (manufacturer setting)
512MB of DDR Ram on 1 stick, PC2100
24x CD-ROM
60GB Toshiba hard drive with 2 partitions, a WinXP using NTFS and an empty fat32
Onboard ATI (not radion) based chipset, 64MB shared ram.

System 3:  IBM Aptiva Model 2161-C9F Pentium based PC (Didn't crash)
Intel Pentium Pro 200MHz (manufacturer setting)
64MB of Ram on 2 sticks (32+32), PC66
16x IBM CD-Rom
3GB IBM hard drive, started with 1 partition, with Win98 using fat32, later 
partioned by red hat 8, but unaltered when upgraded by red hat 9.
ATI Rage II onboard chipset, 2MB SDRam

It might be that I need to install with some options I'm not aware of, but it 
shouldn't crash either way.  I don't think I know the syntax quite right for the 
options, so please be very specific in your answer if that's the case.
Comment 1 Erik 2003-07-19 17:02:21 EDT
I made a typo earlier.  My laptop has a radion IGP 320M.  Its still on
board/shared video.
Comment 2 Michael Fulbright 2003-07-30 12:48:57 EDT
Try turning off USB Legacy Emulation in your laptop BIOS if possible.
Comment 3 Erik 2003-07-30 16:36:31 EDT
Well, now the crashing has stopped, but I still have a problem with my Compaq,
which has a legacy USB keyboard.  I found a temporary to restart my computer &
settings with, but I need a way to use this legacy USB keyboard.  Can I use it
after the install?
Comment 4 Erik 2003-08-04 14:59:23 EDT
Red Hat 9 has been installed on the Compaq, though it is not running very well
(lots of programs crashing, lots of display errors and lots of lagging with a
black screen).  Also, it has rejected the old keyboard, so unless you tell me a
way I can use it, I'm going to have remove red hat.  Also, my laptop has an
incompatible video chipset, so I can't run X on it, and I sure don't want to run
text linux.  I know my second problem is really unrelated to my original
problem, but I still have a valid USB problem on this Compaq.  Mandrake linux
9.1 had no problem with the Compaq keyboard (It just couldn't do much), but I
don't see why red hat can't use my keyboard.
Comment 5 Michael Fulbright 2003-08-11 12:40:14 EDT
This sounds like a kernel driver issue.
Comment 6 Erik 2003-12-07 16:42:01 EST
Its been 4 months since someone has said something to me.  I don't
know if you're busy, or if my problem is unimportant, or whatever. 
I'd be really happy if you would at least tell me if you will or won't
fix my problem someday.  Not that I would know, but is USB 1.0 that
hard to support?
Comment 7 Dave Jones 2003-12-16 14:27:34 EST
Are you no running the latest errata kernel ?
Comment 8 Erik 2003-12-16 19:04:44 EST
I'm on kernel speciallist.  I used whatever kernel came with the Red
Hat 8 and 9 that I downloaded from isolinux.com.  However, I cannot
install RH8 or 9 with Legacy USB support, and if I turn it on after
install I still can't use my keyboard, not to mention all sorts of
weird side-effects occure.  For that matter, it doesn't run very well
with Legacy USB off either, though not as bad.

I'm a half-newbie who's found severel effective ways to ruin an
install but none to fix it.  Thanks for finally replying; I thought
I'd be forgotten about or ignored.
Comment 9 Erik 2003-12-16 19:05:24 EST
*Not a kernel speciallyist (typo) sorry
Comment 10 Dave Jones 2003-12-16 21:16:58 EST
up2date -fu will upgrade to the latest kernel.
Of course, this does mean you'll need to either type this in (using a
different keyboard), or ssh into the box.

You will need an updated kernel than the one that shipped with RHL9 to
work correctly with a radeon IGP chipset.  An alternative if none of
this works is to install Fedora Core 1. This definitly works out of
the box on this chipset, as I have a similar laptop myself.
Comment 11 Erik 2003-12-17 16:33:18 EST
About my laptop, I had to wipe it due to a crashed partition operation
(by Partition Commander 8.1) and am now too scared to put linux back on.

As for my Compaq, its having trouble booting right now because my
master boot record is damaged (including the linux boot loader) and I
don't know how to fix any of it.  I tried removing everything linux,
but I still need third-party software just to boot.  If I ever fix
this, then I'll try this up2date -fu.  However, whenever I've tried
updating RH over the net, everything but updatedrake (for Mandrake
9.1) has crashed in the past, though I've never done up2date -fu.
Comment 12 Erik 2004-06-11 18:34:14 EDT
Here's the new deal: Installed some cheap bootloader from CD,
re-installed Redhat 9, signed up for RHN, ran up2date (today,
6-11-04), ran new kernal, still didn't support keyboard.  

It now says when loading 'USB keyboard: [OK]' but later says the same
old 'USB-control: usb-bulk-message/timedout' or something like that. 
I can't remember exactly.

Sorry I took so long (darn collage taking all my time).
Comment 13 Erik 2004-06-12 18:18:18 EDT
Now I downloaded Fedora Core 2 and used it as an upgrade.  It upgraded
the kernel to yet another new version, and this one supports the
keyboard.  All the problems the upgrade created are unrelated to the
orignial problem so this bug is solved.

Aside from the loss of firewire support, the 8 error messages that
Gnome gives me every boot, and minor Samba issues that are probably my
fault, its working quite well.

Note You need to log in before you can comment on or make changes to this bug.