Bug 994413 - RTGov does not work with file gateway
RTGov does not work with file gateway
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: ---
Assigned To: Gary Brown
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 04:57 EDT by Jiri Pechanec
Modified: 2015-08-02 19:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-254 Major Closed Switchyard camel-service quickstart fails due to class cast exception 2014-07-23 08:50:28 EDT

  None (edit)
Description Jiri Pechanec 2013-08-07 04:57:24 EDT
Try camel-service quickstart. When executed on the server the rtgov does not record a business transaction. Moreover an exception is in the log

10:52:39,114 DEBUG [org.switchyard.internal.EventManager] (Camel (camel-7) thread #8 - file:///home/jpechane/in) Observer threw exception on event class org.apache.camel.management.event.ExchangeCompletedEvent: java.lang.ClassCastException: org.apache.camel.component.file.GenericFileMessage cannot be cast to org.switchyard.bus.camel.CamelMessage
	at org.overlord.rtgov.internal.switchyard.camel.AbstractExchangeEventProcessor.handleEvent(AbstractExchangeEventProcessor.java:77)
	at org.overlord.rtgov.internal.switchyard.AbstractEventProcessor.notify(AbstractEventProcessor.java:75)
	at org.switchyard.internal.EventManager.publish(EventManager.java:52) [switchyard-runtime-1.1.0.M1-redhat-1.jar:1.1.0.M1-redhat-1]
	at org.switchyard.common.camel.event.CamelEventBridge.notify(CamelEventBridge.java:54) [switchyard-common-camel-1.1.0.M1-redhat-1.jar:1.1.0.M1-redhat-1]
	at org.apache.camel.util.EventHelper.doNotifyEvent(EventHelper.java:604) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.util.EventHelper.notifyExchangeDone(EventHelper.java:327) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.impl.DefaultUnitOfWork.done(DefaultUnitOfWork.java:249) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.UnitOfWorkProcessor.doneUow(UnitOfWorkProcessor.java:199) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.UnitOfWorkProcessor.access$000(UnitOfWorkProcessor.java:37) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.UnitOfWorkProcessor$1.done(UnitOfWorkProcessor.java:157) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.RouteContextProcessor$1.done(RouteContextProcessor.java:56) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.Pipeline.process(Pipeline.java:106) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.RouteContextProcessor.processNext(RouteContextProcessor.java:46) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.UnitOfWorkProcessor.processAsync(UnitOfWorkProcessor.java:150) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.UnitOfWorkProcessor.process(UnitOfWorkProcessor.java:117) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.RouteInflightRepositoryProcessor.processNext(RouteInflightRepositoryProcessor.java:48) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.util.AsyncProcessorHelper.process(AsyncProcessorHelper.java:73) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.DelegateAsyncProcessor.processNext(DelegateAsyncProcessor.java:99) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.processor.DelegateAsyncProcessor.process(DelegateAsyncProcessor.java:90) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.management.InstrumentationProcessor.process(InstrumentationProcessor.java:73) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.component.file.GenericFileConsumer.processExchange(GenericFileConsumer.java:336) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.component.file.GenericFileConsumer.processBatch(GenericFileConsumer.java:189) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.component.file.GenericFileConsumer.poll(GenericFileConsumer.java:155) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.impl.ScheduledPollConsumer.doRun(ScheduledPollConsumer.java:142) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at org.apache.camel.impl.ScheduledPollConsumer.run(ScheduledPollConsumer.java:92) [camel-core-2.10.0.redhat-60024.jar:2.10.0.redhat-60024]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_25]
	at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351) [rt.jar:1.7.0_25]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178) [rt.jar:1.7.0_25]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178) [rt.jar:1.7.0_25]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [rt.jar:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_25]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
Comment 1 Gary Brown 2013-08-16 11:49:01 EDT
Have fixed the class cast exception - however no exchange events are being passed to the event listener for this example, so that is the reason that no activity events are recorded.

So that this fix gets into ER2, I am closing this issue, but would suggest creating a separate test for receiving switchyard exchange events - if they are not created, then raise BZ for switchyard, if they are, then raise another BZ against rtgov. Hope that is ok.
Comment 2 JBoss JIRA Server 2013-08-16 11:49:19 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-254 to Resolved
Comment 3 Jiri Pechanec 2013-09-16 06:41:33 EDT
Verified in ER2
Comment 7 JBoss JIRA Server 2014-07-02 05:19:05 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-254 to Closed

Note You need to log in before you can comment on or make changes to this bug.