Bug 994419 - [origin_runtime_175]Client message messes up if gear space is used more than 90%
[origin_runtime_175]Client message messes up if gear space is used more than 90%
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
: 1020076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 05:06 EDT by Qiushui Zhang
Modified: 2015-05-14 20:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:48:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output when the command window is max size (40.93 KB, image/png)
2013-08-20 22:27 EDT, Qiushui Zhang
no flags Details
output when the command window is not in max size (93.17 KB, image/png)
2013-08-20 22:28 EDT, Qiushui Zhang
no flags Details

  None (edit)
Description Qiushui Zhang 2013-08-07 05:06:42 EDT
Description of problem:
The message returned messes up if gear space is used more than 90%

Version-Release number of selected component (if applicable):
devenv_3622
rhc-1.13.0 built from devenv_3622

How reproducible:
always

Steps to Reproduce:
1. Create an app
2. SSH into the app. Add a file which takes more than 90% of gear's total space.
e.g for an app without additional storage, dd if=/dev/zero of=testfile bs=1M count=950
3. rhc app show $appname --gears

Actual results:
520206208fd4a70cac000001 startedCLIENT_MESSAGE: Warning gear 520206208fd4a70cac000001 is using 92.84400939941406 of disk quota  php-5.3    small 520206208fd4a70cac000001@php1-qiuzhang1.dev.rhcloud.com

Expected results:
The "CLIENT_MESSAGE" should be shown after/before the gear info in a new line

Additional info:
Comment 1 Abhishek Gupta 2013-08-19 15:07:31 EDT
On the broker side, we need to make sure that any messages included in the mcollective response are not mixed with the "state" of the gear in the REST response from the broker.
Comment 4 Qiushui Zhang 2013-08-20 22:27:36 EDT
Created attachment 788691 [details]
output when the command window is max size
Comment 5 Qiushui Zhang 2013-08-20 22:28:49 EDT
Created attachment 788692 [details]
output when the command window is not in max size

Checked on devenv_3680. I got the output like the attached screenshot. I have two concerns about the output:
1. The content "php-5.3    small e3ee8cac0a0511e3af8912313b0a852c@php1-qiuzhang.dev.rhcloud.com" should not be in yellow color, since it is not part of the warning message. They are only normal message about "Cartridges, Size and  SSH URL"

2. The output format (when the window is not large enough) is not looking so good.
Comment 8 Qiushui Zhang 2013-10-22 23:13:26 EDT
Tested on devenv_3932.
The client message is printed in a separate line. Looks much better than before.
openshift@openshift-ubuntu:~$ rhc app show rb --gears
Warning gear 52673db26d6c465ab4000007 is using 92.9% of disk quota
ID                       State   Cartridges Size  SSH URL
------------------------ ------- ---------- ----- ----------------------------------------------------
52673db26d6c465ab4000007 started ruby-1.9   small 52673db26d6c465ab4000007@rb-qiuzhang.dev.rhcloud.com

Mark the bug as verified.
Comment 9 Jordan Liggitt 2013-10-23 12:27:04 EDT
*** Bug 1020076 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.