Bug 994435 - Unable to add customised snmp Mib file to /usr/share/snmp/mibs/ location in the rhev-h. After persist also its not going to be available after reboot.
Unable to add customised snmp Mib file to /usr/share/snmp/mibs/ location in t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: 6.4
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 05:43 EDT by Udayendu Sekhar Kar
Modified: 2015-03-22 20:46 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
The /usr/share/snmp/mibs directory was not writeable under the read only root, therefore custom snmp mibs were unable to be installed.The /usr/share/snmp/mibs directory is now read/write which means files can be placed under /usr/share/snmp/mibs now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:48:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18583 None None None Never

  None (edit)
Description Udayendu Sekhar Kar 2013-08-07 05:43:07 EDT
Description of problem:
Created a custom Mib file for the snmp on the rhev-h and added it to /usr/share/snmp/mibs/ directory and persisted it but post reboot the file is missing.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20130709.0.el6_4)

How reproducible:
100%

Steps to Reproduce:
# mount -o remount,rw /
# vi /usr/share/snmp/mibs/test-MIB.txt
# persist /usr/share/snmp/mibs/test-MIB.txt
# mount -o remount,ro /

Now reboot the host. Once the host will back you will not get the "test-MIB.txt" file but the entry is there under /config/files file.

Actual results:
After the host reboot the custom file is missing.

Expected results:
The custome file shouldn't erased after the server reboot as its already persisted.
Comment 2 Mike Burns 2013-08-14 09:19:16 EDT
devel thoughts

perhaps add this to the default persisted locations?  Can we do that in the plugin?  need to investigate why the file is getting dropped if it's persisted.
Comment 3 Joey Boggs 2013-08-26 21:39:34 EDT
http://gerrit.ovirt.org/18583
Comment 4 Joey Boggs 2013-08-26 21:41:01 EDT
The file wasn't being mounted correctly due to the irregular directory path under /usr/share. If it was under any of the rwtab entries it would work fine.
Comment 9 Cheryn Tan 2013-11-07 19:34:07 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 Ying Cui 2013-11-10 22:07:37 EST
Verified this bug on build rhevh-6.5-20131031.1.0, ovirt-node-3.0.1-7.el6.noarch, ovirt-node-plugin-snmp-3.0.1-7.el6.noarch.

Test steps:

# mount -o remount,rw /
# vi /usr/share/snmp/mibs/test-MIB.txt
# persist /usr/share/snmp/mibs/test-MIB.txt
# mount -o remount,ro /
# reboot RHEV-H
# cat /config/files | grep mib
/usr/share/snmp/mibs/test-MIB.txt
# pwd
/usr/share/snmp/mibs
# ls |grep test-MIB
test-MIB.txt

Test result:
1. the customised snmp mib file is persist successful after reboot rhevh.
Comment 12 errata-xmlrpc 2014-01-21 14:48:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.