Bug 994445 - Should return meaningful error message when creating app meets No nodes available.
Should return meaningful error message when creating app meets No nodes avail...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 06:11 EDT by Meng Bo
Modified: 2015-05-14 19:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:49:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-08-07 06:11:40 EDT
Description of problem:
Create app on node with the condition that no nodes available. eg, Create medium gear on small node, or create gear on node with no capacity. Will get meaningless error message with Reference ID.

  <messages>
    <message>
      <severity>error</severity>
      <text>Unable to complete the requested operation because the system is unavailable. If the problem persists please contact Red Hat support. 
Reference ID: 6c3a566564ef622917b4d481f81b45e9</text>
      <exit-code>140</exit-code>
      <field nil="true"></field>
    </message>
  </messages>

Version-Release number of selected component (if applicable):
always

How reproducible:
devenv_3622

Steps to Reproduce:
1. Launch single instance with small node profile and NODE_PROFILE_ENABLED=true
2. Try to create a medium size gear on the node
3.

Actual results:
Creation fail, with meaningless error.

      <severity>error</severity>
      <text>Unable to complete the requested operation because the system is unavailable. If the problem persists please contact Red Hat support. 
Reference ID: 6c3a566564ef622917b4d481f81b45e9</text>
      <exit-code>140</exit-code>
      <field nil="true"></field>

Expected results:
Should return meaningful error message "No nodes available."

Additional info:
<---snip--->
Creating application 'app3' ... 
Unable to complete the requested operation because the system is unavailable. If the problem persists please contact Red Hat support. 
Reference ID: 4f5212abf8acbef43b9b664bf16e7ac5

[root@ip-10-100-219-10 ~]# grep 4f5212abf8acbef43b9b664bf16e7ac5 /var/log/openshift/broker/development.log 
2013-08-07 05:35:25.178 [ERROR] Reference ID: 4f5212abf8acbef43b9b664bf16e7ac5 - No nodes available.
Comment 1 Jason DeTiberus 2013-08-19 23:06:43 EDT
https://github.com/openshift/origin-server/pull/3398
Comment 2 Meng Bo 2013-08-20 06:08:55 EDT
Checked on devenv_3678, issue has been fixed.


# rhc app create app3 php-5 --no-dns
Using php-5.3 (PHP 5.3) for 'php-5'

Application Options
-------------------
  Namespace:  bmeng2
  Cartridges: php-5.3
  Gear Size:  default
  Scaling:    no

Creating application 'app3' ... 
Unable to complete the requested operation due to: No nodes available. If the problem persists please contact Red Hat support. 
Reference ID: 0cdbb5a0429f52ed711d6c232628dcd7


Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.