Bug 994446 - Firewall-config doesn't work with fluxbox
Firewall-config doesn't work with fluxbox
Status: CLOSED DUPLICATE of bug 995760
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 06:12 EDT by Frank Becker
Modified: 2013-08-16 11:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 11:48:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Becker 2013-08-07 06:12:18 EDT
Description of problem:
On my F19 system I work with XFCE4 and Fluxbox. If I call firewall-config from xfce4 as user, everything works fine. Because I'm a member of the group wheel a window appears to enter the password.
With Fluxbox, no window appears to enter a password. A window with "Authorisation error" with OK Cancel.

If I press ok several times the following message appears in the console:
Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 932, in onChangeZone
    _services = services[:]
TypeError: 'NoneType' object has no attribute '__getitem__'


It is not possible to use firewall-config in Fluxbox.
Comment 1 Jiri Popelka 2013-08-16 11:48:38 EDT
(In reply to Frank Becker from comment #0)
> With Fluxbox, no window appears to enter a password.

Depends whether there is a polkit authentication agent running.
I don't know about Fluxbox, for GNOME one needs a polkit-gnome package, for KDE it's called polkit-kde.

> If I press ok several times the following message appears in the console:

I've been clicking like mad but can't reproduce it, sorry.

*** This bug has been marked as a duplicate of bug 995760 ***

Note You need to log in before you can comment on or make changes to this bug.