Bug 994447 - "stopping libvirtd daemon: [FAILED]" and "diff: /etc/init/libvirtd.conf: No such file or directory" seen during first boot of RHS 2.1 [NEEDINFO]
"stopping libvirtd daemon: [FAILED]" and "diff: /etc/init/libvirtd.conf: No s...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Timothy Asir
SATHEESARAN
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 06:12 EDT by Gowrishankar Rajaiyan
Modified: 2015-05-12 19:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-12 19:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sabose: needinfo? (dpati)


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2013-08-07 06:12:30 EDT
Description of problem: During first boot, I see "stopping libvirtd daemon: [FAILED]" and "diff: /etc/init/libvirtd.conf: No such file or directory". 


Version-Release number of selected component (if applicable):
RHS-2.1-20130806.n.2

How reproducible: Always


Steps to Reproduce:
1. Install RHS 2.1 using PXE
2. Ensure to include "yum install -y xfsprogs tuned glusterfs-server redhat-storage-server" in %post of your kickstart.
3. Reboot virtual machine post successful install.

Actual results: During first boot, I see "stopping libvirtd daemon: [FAILED]" and "diff: /etc/init/libvirtd.conf: No such file or directory".


<snip>
Starting sm-client: [  OK  ]
Starting ksm: [  OK  ]
Starting ksmtuned: [  OK  ]


>>>Stopping libvirtd daemon: [FAILED] <<<


Configuring a self-signed VDSM host certificate: [  OK  ]
Configuring libvirt for vdsm...
Starting iscsid...
Starting multipathd...
Starting multipathd daemon: [  OK  ]
Starting wdmd...
Loading the softdog kernel module: Software Watchdog Timer: 0.07 initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout= 0)
[  OK  ]
Starting wdmd: [  OK  ]
Starting sanlock...
Starting sanlock: [  OK  ]
Starting iscsid: Loading iSCSI transport class v2.0-870.
iscsi: registered transport (tcp)
iscsi: registered transport (iser)
libcxgbi:libcxgbi_init_module: tag itt 0x1fff, 13 bits, age 0xf, 4 bits.
libcxgbi:ddp_setup_host_page_size: system PAGE 4096, ddp idx 0.
Chelsio T3 iSCSI Driver cxgb3i v2.0.0 (Jun. 2010)
iscsi: registered transport (cxgb3i)
Chelsio T4 iSCSI Driver cxgb4i v0.9.1 (Aug. 2010)
iscsi: registered transport (cxgb4i)
cnic: Broadcom NetXtreme II CNIC Driver cnic v2.5.13 (Sep 07, 2012)
Broadcom NetXtreme II iSCSI Driver bnx2i v2.7.2.2 (Apr 26, 2012)
iscsi: registered transport (bnx2i)
iscsi: registered transport (be2iscsi)
In beiscsi_module_init, tt=ffffffffa034e760
[  OK  ]


>>>diff: /etc/init/libvirtd.conf: No such file or directory<<<


Ebtables v2.0 registered
ip_tables: (C) 2000-2006 Netfilter Core Team
ip6_tables: (C) 2000-2006 Netfilter Core Team
Bridge firewalling registered
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: bond4 is being created...
bonding: bond1 is being created...
bonding: bond2 is being created...
bonding: bond3 is being created...
Starting up vdsm daemon: 
vdsm start[  OK  ]
</snip>
Comment 2 Timothy Asir 2013-09-03 04:35:01 EDT
This is because when vdsm is starting, it wants to shutdown libvirt daemon and configure it, then it starts libvirt daemon again. But during the first boot, libvirt is not started yet, so vdsm says it fails to stop libvirtd, this is fine.
After the first boot, libvirt is configured so vdsm will not attempt to configure it again, then you no longer see this message.
Comment 3 Dan Kenigsberg 2013-09-25 17:28:03 EDT
This annoying (yet harmless) warning is going to be gone with Zhou's new handling of services by vdsmd.
Comment 4 Gowrishankar Rajaiyan 2013-10-03 05:15:52 EDT
"Fixed In Version: IS16 → glusterfs-3.4.0.33rhs-1"

This doesn't look like a gluster bug.
Comment 5 Gowrishankar Rajaiyan 2013-10-03 07:45:32 EDT
Still see this:

...
Starting ksmtuned: [  OK  ]
Stopping libvirtd daemon: [FAILED]
Configuring a self-signed VDSM host certificate: [  OK  ]
Configuring libvirt for vdsm...
...
[  OK  ] iscsid: [  OK  ]
diff: /etc/init/libvirtd.conf: No such file or directory
Starting up vdsm daemon: 
...

Tested with build: RHSS-2.1-20130910.0/2.1
Comment 6 Yaniv Bronhaim 2013-10-19 11:50:50 EDT
What is wrong with those prints? it was there really long time until we submitted a patch upstream to send this output to /dev/null rightly , we can backport it if needed, but it doesn't effect anything. IMHO, its better to leave it as is than backport unnecessary code if it's harmless
Comment 7 Dusmant 2013-10-31 05:58:24 EDT
No need to take it in Corbett...
Comment 8 Vivek Agarwal 2013-11-12 08:42:28 EST
Removing the Not-In-Corbett from internal white board
Comment 9 Sahina Bose 2014-07-24 16:15:02 EDT
This one's probably a WONT FIX for 2.1, as there's no backport to 2.1 but error print is fixed in RHS 3.0

Dusmant, please mark accordingly if you think likewise
Comment 11 Dan Kenigsberg 2015-05-12 19:29:26 EDT
Since my comment 3, Zhou's service reworked had fixed this issue (and others).
I don't see any point of tracking this ancient bug.

Note You need to log in before you can comment on or make changes to this bug.